9XR Pro + Multiiprotocol + Inductrix FPV

Programing help and example for all firmwares based on thus's th9 firmware.
Post Reply
airwolfe
Posts: 8
Joined: Thu Jan 19, 2017 2:12 pm
Country: -

9XR Pro + Multiiprotocol + Inductrix FPV

Post by airwolfe » Thu Jan 19, 2017 2:17 pm

Hello, need some help, I have a bnf fpv inductrix and I just got the 4n1 module and I get it to bind finally. However, it will not move. Nothing I do to the control results in any action from the drone. I have my settings for the mutli protocol dsm(DSMX-22, autobind =y, 8ch, rxnum8, trainer polarity pos, power=high, rate 7ms, 1st chan=6, module tx and rx nodes on the board are bridged.
Please help...

User avatar
MikeB
9x Developer
Posts: 15619
Joined: Tue Dec 27, 2011 1:24 pm
Country: -
Location: Poole, Dorset, UK

Re: 9XR Pro + Multiiprotocol + Inductrix FPV

Post by MikeB » Thu Jan 19, 2017 2:23 pm

Why first chan = 6? Try setting this back to 1.
If first chan is set to 6, then the mixer channels 1 to 5 are not being used, channel 6 is sent as channel 1 to the module.

Mike.
ersky9x/er9x developer
The difficult we do immediately,
The impossible takes a little longer!

airwolfe
Posts: 8
Joined: Thu Jan 19, 2017 2:12 pm
Country: -

Re: RE: Re: 9XR Pro + Multiiprotocol + Inductrix FPV

Post by airwolfe » Thu Jan 19, 2017 7:55 pm

MikeB wrote:Why first chan = 6? Try setting this back to 1.
If first chan is set to 6, then the mixer channels 1 to 5 are not being used, channel 6 is sent as channel 1 to the module.

Mike.
Thx, I will check that when I get home. And again for being patient I'm new to all this..

Sent from my SM-G920V using Tapatalk

airwolfe
Posts: 8
Joined: Thu Jan 19, 2017 2:12 pm
Country: -

Re: 9XR Pro + Multiiprotocol + Inductrix FPV

Post by airwolfe » Thu Jan 19, 2017 10:39 pm

Mike, I changed it to ch1 and it seems to bind but the controls are wonkie.

airwolfe
Posts: 8
Joined: Thu Jan 19, 2017 2:12 pm
Country: -

Re: RE: Re: 9XR Pro + Multiiprotocol + Inductrix FPV

Post by airwolfe » Fri Jan 20, 2017 12:01 am

airwolfe wrote:Mike, I changed it to ch1 and it seems to bind but the controls are wonkie.
it does seem to turn on the motors atleast

Sent from my SM-G920V using Tapatalk


airwolfe
Posts: 8
Joined: Thu Jan 19, 2017 2:12 pm
Country: -

Re: 9XR Pro + Multiiprotocol + Inductrix FPV

Post by airwolfe » Fri Jan 20, 2017 4:05 am

Everything is in reverse. my right sticket controls the throttle to some degree but only at a angle.(bottom left) which also activates the drone.

LutzB
Posts: 29
Joined: Tue May 19, 2015 3:21 pm
Country: Germany

Re: 9XR Pro + Multiiprotocol + Inductrix FPV

Post by LutzB » Fri Jan 20, 2017 6:28 am

Please check your channel order: 1=T, 2=A, 3=E, 4=R, 6=Mode
I am using a taranis with a old DX4 module, so it might be different to your setup. But this is the way it works for me. You can also search for a NanoQX setup, as it is the same configuration.

Lutz

User avatar
jhsa
Posts: 17815
Joined: Tue Dec 27, 2011 5:13 pm
Country: Germany

Re: 9XR Pro + Multiiprotocol + Inductrix FPV

Post by jhsa » Fri Jan 20, 2017 6:48 am

If he is using the 4 in 1 multi module, I believe the channel order should be AETR?
Also what stick mode do you fly? Is your throttle on the left, or on the right?

João
My er9x/Ersky9x/eepskye Video Tutorials
https://www.youtube.com/playlist?list=PL5uJhoD7sAKidZmkhMpYpp_qcuIqJXhb9

Donate to Er9x/Ersky9x:
https://www.paypal.com/cgi-bin/webscr?cmd=_s-xclick&hosted_button_id=YHX43JR3J7XGW

User avatar
Kilrah
Posts: 9518
Joined: Sat Feb 18, 2012 6:56 pm
Country: Switzerland

Re: 9XR Pro + Multiiprotocol + Inductrix FPV

Post by Kilrah » Fri Jan 20, 2017 8:35 am

Yes, multimodule needs AETR.

airwolfe
Posts: 8
Joined: Thu Jan 19, 2017 2:12 pm
Country: -

Re: 9XR Pro + Multiiprotocol + Inductrix FPV

Post by airwolfe » Fri Jan 20, 2017 1:34 pm

my throttle is on the left. mode2 however I had to change it to mode 1 to make the drone work correctly some what.

User avatar
Kilrah
Posts: 9518
Joined: Sat Feb 18, 2012 6:56 pm
Country: Switzerland

Re: 9XR Pro + Multiiprotocol + Inductrix FPV

Post by Kilrah » Fri Jan 20, 2017 1:51 pm

That will work but is not correct, you should leave it in mode 2 and change ordering in the mixer.

airwolfe
Posts: 8
Joined: Thu Jan 19, 2017 2:12 pm
Country: -

Re: 9XR Pro + Multiiprotocol + Inductrix FPV

Post by airwolfe » Fri Jan 20, 2017 4:16 pm

ooh ok, I will do that. I got it to fly but its like on the throttle there is a dead spot and its not all the way down. All the way down goes in reverse... when I get home I will work on it some more.

User avatar
jhsa
Posts: 17815
Joined: Tue Dec 27, 2011 5:13 pm
Country: Germany

Re: 9XR Pro + Multiiprotocol + Inductrix FPV

Post by jhsa » Fri Jan 20, 2017 4:22 pm

Did you calibrate your radio's sticks?

João
My er9x/Ersky9x/eepskye Video Tutorials
https://www.youtube.com/playlist?list=PL5uJhoD7sAKidZmkhMpYpp_qcuIqJXhb9

Donate to Er9x/Ersky9x:
https://www.paypal.com/cgi-bin/webscr?cmd=_s-xclick&hosted_button_id=YHX43JR3J7XGW

airwolfe
Posts: 8
Joined: Thu Jan 19, 2017 2:12 pm
Country: -

Re: RE: Re: 9XR Pro + Multiiprotocol + Inductrix FPV

Post by airwolfe » Fri Jan 20, 2017 4:26 pm

jhsa wrote:Did you calibrate your radio's sticks?

João
I believe so but I will do that again when I get home. Thx for the help.

Sent from my SM-G920V using Tapatalk

LutzB
Posts: 29
Joined: Tue May 19, 2015 3:21 pm
Country: Germany

Re: 9XR Pro + Multiiprotocol + Inductrix FPV

Post by LutzB » Fri Jan 20, 2017 4:49 pm

airwolfe wrote:ooh ok, I will do that. I got it to fly but its like on the throttle there is a dead spot and its not all the way down. All the way down goes in reverse... when I get home I will work on it some more.
I also noticed this behavior on the throttle channel. I had to raise the min value quite a lot.

Post Reply

Return to “er9x / gruvin9x / th9 based firmwares”