9XR Pro + FrSky DJT + FrSky D8R-ii Pro (flashed 27ms firmware) not binding

Programing help and example for all firmwares based on thus's th9 firmware.
Post Reply
sportsfan12321
Posts: 11
Joined: Mon Aug 15, 2016 1:07 pm
Country: -

9XR Pro + FrSky DJT + FrSky D8R-ii Pro (flashed 27ms firmware) not binding

Post by sportsfan12321 » Mon Aug 15, 2016 1:18 pm

Hi all,

I'm having binding issues with my transmitter/receiver. Summary:

- FrSky D8R-ii Plus was flashed to the 27ms D8R-XP firmware for CPPM support (http://www.frsky-rc.com/download/view.p ... are-D8R-XP). The jumper is on ch3-4 signals (as needed for the XP to be in PPM mode)
- 9XR Pro is in PPM mode, with FrLen set to 27ms
- Both dip switches on DJT are in OFF position
- I hold the bind button on DJT and turn TX on, get a solid green and fast blinking red light on DJT
- I hold the F/S button on D8R-ii, supply 5V power, and let go of F/S button. A solid green and solid red light appear. This is unexpected behavior.
- I then power down both TX and RX, then power back up. The D8R-ii is flashing a red light (meaning no bind). The 9XR is showing RSSI = 0.

I've also tried flashing my DJT to the v2 firmware (http://www.frsky-rc.com/download/view.p ... HT/DJT/DFT) which is currently on it, with no luck. Also tried binding at various distances/angles, no luck.

The situation is similar to those being described in these links:
http://www.frsky-rc.com/BBS/viewtopic.php?f=4&t=7204
viewtopic.php?t=7839
viewtopic.php?t=1455
https://www.youtube.com/watch?v=ZFn6Owm ... e=youtu.be
http://www.rcgroups.com/forums/showthread.php?t=1481859

Any help is really appreciated. Thanks ahead!

User avatar
Kilrah
Posts: 9495
Joined: Sat Feb 18, 2012 6:56 pm
Country: Switzerland

Re: 9XR Pro + FrSky DJT + FrSky D8R-ii Pro (flashed 27ms firmware) not binding

Post by Kilrah » Mon Aug 15, 2016 3:54 pm

What about removing the jumper before binding and putting it back afterwards?

sportsfan12321
Posts: 11
Joined: Mon Aug 15, 2016 1:07 pm
Country: -

Re: 9XR Pro + FrSky DJT + FrSky D8R-ii Pro (flashed 27ms firmware) not binding

Post by sportsfan12321 » Mon Aug 15, 2016 11:02 pm

Kilrah wrote:What about removing the jumper before binding and putting it back afterwards?
Thanks for your reply.

No change in behavior when I try that...

Also tried switching PPM mode from opendrain to full drive, no change.

User avatar
MikeB
9x Developer
Posts: 15565
Joined: Tue Dec 27, 2011 1:24 pm
Country: -
Location: Poole, Dorset, UK

Re: 9XR Pro + FrSky DJT + FrSky D8R-ii Pro (flashed 27ms firmware) not binding

Post by MikeB » Tue Aug 16, 2016 8:54 am

If the Rx was binding OK BEFORE you flashed it with the 27mS firmware, I suggest you try to put the Rx firmware back to standard and then try binding.
If you have another Rx, does that bind OK?

Mike.
ersky9x/er9x developer
The difficult we do immediately,
The impossible takes a little longer!

sportsfan12321
Posts: 11
Joined: Mon Aug 15, 2016 1:07 pm
Country: -

Re: 9XR Pro + FrSky DJT + FrSky D8R-ii Pro (flashed 27ms firmware) not binding

Post by sportsfan12321 » Tue Aug 16, 2016 12:13 pm

MikeB wrote:If the Rx was binding OK BEFORE you flashed it with the 27mS firmware, I suggest you try to put the Rx firmware back to standard and then try binding.
If you have another Rx, does that bind OK?

Mike.
I had not attempted to bind before, but I did try flashing to the original firmware and no dice still. Sadly I don't have another Rx to try this on. I'm thinking it might just be a defective unit...


User avatar
MikeB
9x Developer
Posts: 15565
Joined: Tue Dec 27, 2011 1:24 pm
Country: -
Location: Poole, Dorset, UK

Re: 9XR Pro + FrSky DJT + FrSky D8R-ii Pro (flashed 27ms firmware) not binding

Post by MikeB » Tue Aug 16, 2016 2:40 pm

Try binding by turning the Rx on first, holding the button pressed, then power on the radio with the button pressed on the DJT. The Rx indicates binding is complete by flashing the RED LED.

Mike.
ersky9x/er9x developer
The difficult we do immediately,
The impossible takes a little longer!

sportsfan12321
Posts: 11
Joined: Mon Aug 15, 2016 1:07 pm
Country: -

Re: 9XR Pro + FrSky DJT + FrSky D8R-ii Pro (flashed 27ms firmware) not binding

Post by sportsfan12321 » Wed Aug 17, 2016 1:30 pm

MikeB wrote:Try binding by turning the Rx on first, holding the button pressed, then power on the radio with the button pressed on the DJT. The Rx indicates binding is complete by flashing the RED LED.

Mike.
Tried that as well, no change in behavior...

sportsfan12321
Posts: 11
Joined: Mon Aug 15, 2016 1:07 pm
Country: -

Re: 9XR Pro + FrSky DJT + FrSky D8R-ii Pro (flashed 27ms firmware) not binding

Post by sportsfan12321 » Fri Aug 19, 2016 5:29 am

So I got a new receiver and was able to bind to it (after many many tries), and although I sometimes get a green light, the binding seems to be very erratic (quickly switches back and forth between the green light on RX to the slow flashing light, with a beep from the TX each time this happens). Any ideas? Could WiFi interference be causing this?

User avatar
jhsa
Posts: 17724
Joined: Tue Dec 27, 2011 5:13 pm
Country: Germany

Re: 9XR Pro + FrSky DJT + FrSky D8R-ii Pro (flashed 27ms firmware) not binding

Post by jhsa » Fri Aug 19, 2016 7:49 am

Do you have another antenna you could try on the DJT?

João
My er9x/Ersky9x/eepskye Video Tutorials
https://www.youtube.com/playlist?list=PL5uJhoD7sAKidZmkhMpYpp_qcuIqJXhb9

Donate to Er9x/Ersky9x:
https://www.paypal.com/cgi-bin/webscr?cmd=_s-xclick&hosted_button_id=YHX43JR3J7XGW

sportsfan12321
Posts: 11
Joined: Mon Aug 15, 2016 1:07 pm
Country: -

Re: 9XR Pro + FrSky DJT + FrSky D8R-ii Pro (flashed 27ms firmware) not binding

Post by sportsfan12321 » Fri Aug 19, 2016 2:27 pm

jhsa wrote:Do you have another antenna you could try on the DJT?

João
Tried a different one, but still the same behavior...also tried flashing my 9xr pro to ersky9xr-r218 (previously it was 212), but no change. This is getting a bit frustrating.

sportsfan12321
Posts: 11
Joined: Mon Aug 15, 2016 1:07 pm
Country: -

Re: 9XR Pro + FrSky DJT + FrSky D8R-ii Pro (flashed 27ms firmware) not binding

Post by sportsfan12321 » Sat Sep 03, 2016 4:35 pm

For those facing the same issues in the future, it turned out to be a bad transmitter module. My hypothesis is that something was wrong with the pin alignment when I plugged it into my 9XR. Got a replacement and everything works smoothly on the first try.

Post Reply

Return to “er9x / gruvin9x / th9 based firmwares”