Companion 2.1.7 wont read from Taranis

A fork of eePe. It's aim is to provide one tool that works with ALL firmwares!
Post Reply
ChopperHorse
Posts: 6
Joined: Fri Apr 01, 2016 5:31 am
Country: -

Companion 2.1.7 wont read from Taranis

Post by ChopperHorse » Fri Apr 01, 2016 6:43 am

Hi everyone.
I got my Taranis back from getting haptic installed, It came back with 2.1.7 on it so I down loaded companion 2.1.7 (lucky I saved the model memory before I sent it off!). I wrote the old memory back to the radio and it seams to work well, but when I try to read it back into companion I get
ERROR
"Invalid binary EEPROM file C:/ Users/Marcus/AppData/Local/Temp/6176-temp.bin
Possible causes for this:
-Eeprom size is invalid
-something that couldn't be guessed, sorry"

Rcgroups has tried to help and recommended I try here.
What was looked at on rcgroups
-I am using the correct companion 2.1.7 and have tried re-installing it. (older versions are installed but that shouldn't be the problem)
-the bootloader is 2.1.6 and should not be a problem
-Taranis (non-plus), haptic and en. are selected in the "radio profile" box in companion
-the "configure communications" in settings says C:/Users/Marcus/Desktop/opentx companion 2.1x/Companion 2.1/dfu-util.exe and appears to be correct.
-The 2 drives appear as 2 auto play boxes one TARANIS (F:) with 2 options to "use this drive for backup"
and a folder with EEPROM.BIN (64kb) and FIRMWARE>BIN (512kb).
The other box says Removable Disk (E:) that in mixed contents has play,add files.copydisk,import pictures and videos,view pictures,MP navigator EX Ver4.1 and in general options has a file with (sounds,models.logs,info,docs,BMP )in it ,then , Use this drive for backup, Speed up my system.
There are the 3 models I have on the taranis at 1kb each in the models file.
- I have tried downloading firmware (opentx-taranis-haptic-en.bin ) via companion 2.1.7 and cut-pasting into the (F:)SD card then writing it onto the Taranis, it loaded but then still the same error box.

I am not great with computers but can follow instructions. Any help is much appreciated.

User avatar
Kilrah
Posts: 9560
Joined: Sat Feb 18, 2012 6:56 pm
Country: Switzerland

Re: Companion 2.1.7 wont read from Taranis

Post by Kilrah » Fri Apr 01, 2016 7:10 am

Seems to be a companion bug. Reported here: https://github.com/opentx/opentx/issues/3394

ChopperHorse
Posts: 6
Joined: Fri Apr 01, 2016 5:31 am
Country: -

Re: Companion 2.1.7 wont read from Taranis

Post by ChopperHorse » Fri Apr 01, 2016 7:32 am

Brilliant, I was worried I had an orphan problem on my hands!, This is the best news I have had all week thanks Kilrah.
As its been listed as a companion bug fix, does this mean I am safe to re-start setting up models on the radio without any chance of losing my work when I download 2.1.8 ?. And if I guessed that 2.1.8 will come out an a month or 2 would that be as good a guess as any??. Just worried about losing all that work again!.
Marcus

User avatar
Kilrah
Posts: 9560
Joined: Sat Feb 18, 2012 6:56 pm
Country: Switzerland

Re: Companion 2.1.7 wont read from Taranis

Post by Kilrah » Fri Apr 01, 2016 7:44 am

Can't tell you much for now, don't know if it's really a companion bug or a problem has crept up in 2.0->2.1 conversion.

ChopperHorse
Posts: 6
Joined: Fri Apr 01, 2016 5:31 am
Country: -

Re: Companion 2.1.7 wont read from Taranis

Post by ChopperHorse » Fri Apr 01, 2016 7:45 am

Ok thanks


ChopperHorse
Posts: 6
Joined: Fri Apr 01, 2016 5:31 am
Country: -

Re: Companion 2.1.7 wont read from Taranis

Post by ChopperHorse » Sat Apr 02, 2016 8:38 am

OK, since I figure it may be months untill the bug is fixed, I decided to start again by deleting all my models, Re-flash 2.1.7 firmware and re-create them on the Taranis. I did one then tried to read it back into companion 2.1.7 and I got the same error. I then tried to create one in companion 2.1.7 and it went onto the Taranis fine, but again it could not be read back into companion. These new models have never seen anything other then 2.1.7 apart from the 2.1.6 bootloader so where can I go from here??.

User avatar
Kilrah
Posts: 9560
Joined: Sat Feb 18, 2012 6:56 pm
Country: Switzerland

Re: Companion 2.1.7 wont read from Taranis

Post by Kilrah » Sat Apr 02, 2016 9:43 am

That's definitely not supposed to be a problem... Can you check that you have no hard drive or USB drive connected to your computer that has a file named "EEPROM.BIN" at the root by any chance, other than the Taranis' own virtual drive that would have EEPROM.BIN and FIRMWARE.BIN?

ChopperHorse
Posts: 6
Joined: Fri Apr 01, 2016 5:31 am
Country: -

Re: Companion 2.1.7 wont read from Taranis

Post by ChopperHorse » Sat Apr 02, 2016 10:17 am

Nothing but the Taranis is connected and I did a search in the windows 7 start menu for EEPROM.BIN, and only the shortcut to the file I pulled out of the Taranis drive into the recycle bin that I left on the desktop came up in the search (I then put it in the recycle as well). The new EEPROM.BIN and FIRMWARE.BIN are in the Taranis drive (identical to the ones I deleted I assume) like the old ones were. Those files are still in the recycle bin and didn't show up in the search like I thought they would -just to say I am no computer expert!.

In the devices and printers part it shows the Taranis, the laptop itself and the mouse, as well as a few wifi printers but nothing has changed with my computer since companion 2.0.x used to work.

User avatar
Kilrah
Posts: 9560
Joined: Sat Feb 18, 2012 6:56 pm
Country: Switzerland

Re: Companion 2.1.7 wont read from Taranis

Post by Kilrah » Sat Apr 02, 2016 12:39 pm

You cannot delete those files from the Taranis drive. The drive is virtual and does not behave like a normal disk, you should actually never touch it manually.

You have to do a "Factory Reset" in the radio (on the version screen) if you want to erase everything.

ChopperHorse
Posts: 6
Joined: Fri Apr 01, 2016 5:31 am
Country: -

Re: Companion 2.1.7 wont read from Taranis

Post by ChopperHorse » Sat Apr 02, 2016 1:47 pm

Oh well its still working the same as before. I have re-set up some old models again (downloaded via companion) and am partly resigned to not being able to use companion. I have bought a USB micro SD card reader so I can at least feel safe having a back up for them saved.

Masher
Posts: 4
Joined: Sun May 22, 2016 2:20 pm
Country: -

Re: Companion 2.1.7 wont read from Taranis

Post by Masher » Sun May 22, 2016 2:23 pm

Hi ChopperHorse

Did you get tis sorted? I have just upgraded to 2.1.9 and have the same problem and same error message.
Tried everything and cannot clear it.
Taranis is working fine and I can change all my models by hand (mainly just telemetry) but Companion should work!
Thanks

Masher
Posts: 4
Joined: Sun May 22, 2016 2:20 pm
Country: -

Re: Companion 2.1.7 wont read from Taranis

Post by Masher » Mon May 23, 2016 8:50 am

And today, just because this bugs me, I went back to 2.0 version after stripping everything off the SD card - guess what, get the same error message on 2.0 now too!

I get the same result on 3 PC's, there are no other files called EEPROM.bin and the one on the Taranis drive dates back to some years ago.

The answer will be obvious when we find it!

Masher
Posts: 4
Joined: Sun May 22, 2016 2:20 pm
Country: -

Re: Companion 2.1.7 wont read from Taranis

Post by Masher » Tue May 31, 2016 2:35 pm

Well to answer yourself Masher, the answer is blindingly obvious. Companion only comes up with the EEPROM error if you select the 'read from radio' icon. If however, you select 'open file' and choose the latest EEPROM file from your SD card, Bob's your aunty!

User avatar
Kilrah
Posts: 9560
Joined: Sat Feb 18, 2012 6:56 pm
Country: Switzerland

Re: Companion 2.1.7 wont read from Taranis

Post by Kilrah » Tue May 31, 2016 3:07 pm

That shouldn't make a difference... and thus reinforces the suggestion you have a file on another drive.

Masher
Posts: 4
Joined: Sun May 22, 2016 2:20 pm
Country: -

Re: Companion 2.1.7 wont read from Taranis

Post by Masher » Tue May 31, 2016 4:14 pm

Well it's academic now but I do not have a file on another drive that I can find. The result is identical on 3 different PC's.

stormhigh
Posts: 1
Joined: Sun Jun 12, 2016 8:11 pm
Country: -

Re: Companion 2.1.7 wont read from Taranis

Post by stormhigh » Sun Jun 12, 2016 8:29 pm

I have the same problem with Companion 2.1.8 and "217"eeprom. Cannot read with Companion, only write. Solved the problem with making by Taranis eeprom-Backup ("restore eeprom") on SD-Card. With Companion I can open this eeprom-file, and do everything same way I would have done the usual way.
Good success and best regards!

barjunk
Posts: 42
Joined: Thu Jun 19, 2014 2:51 am
Country: -

Re: Companion 2.1.7 wont read from Taranis

Post by barjunk » Sun Jul 10, 2016 6:51 pm

It may not be relevant to the others having problems here, but in my case, if I unmounted the USB devices improperly, it caused companion to not "detect" the radio.

Properly unmounting the devices corrected the issue for me.

While it was confusing to have companion complain that it could not connect to the radio even though the OS could see everything, I like that it was careful about working with a "dirty" SD card.

Thoughts?

Can anyone else confirm this?

barjunk
Posts: 42
Joined: Thu Jun 19, 2014 2:51 am
Country: -

Re: Companion 2.1.7 wont read from Taranis

Post by barjunk » Sun Jul 10, 2016 7:30 pm

While we are at it, what is the latest BootLoader and should the eepr number be the same as the VERS only without the dots? I have the following on my radio:

Bootloader: 2.0.9 (found when I do three finger startup)

Found the following on page 5 of the Radio Setup menu
FW: opentx-taranis-plus
VERS: 2.1.6
EEPR: 217

Thanks for any clarification. I'll add it to the OpenTx manual once I get it straight in my head.

User avatar
Kilrah
Posts: 9560
Joined: Sat Feb 18, 2012 6:56 pm
Country: Switzerland

Re: Companion 2.1.7 wont read from Taranis

Post by Kilrah » Sun Jul 10, 2016 8:05 pm

barjunk wrote:It may not be relevant to the others having problems here, but in my case, if I unmounted the USB devices improperly, it caused companion to not "detect" the radio.

Properly unmounting the devices corrected the issue for me.
I can see how failing to properly unmount the drive could cause changes made in companion not to be reflected on the radio, but not why companion wouldn't read it next time you connect the radio (providing I understood that part well, it isn't clear when reading doesn't work from your post).

Latest bootloader version is always the same as the latest firmware version (even if there usually aren't actually changes to it, see release notes for info), EEPR version is NOT "main version minus dots", it only gets incremented on major releases (2.0, 2.1, 2.2) if necessary.

barjunk
Posts: 42
Joined: Thu Jun 19, 2014 2:51 am
Country: -

Re: Companion 2.1.7 wont read from Taranis

Post by barjunk » Tue Jul 12, 2016 4:40 am

OK. I did so more testing.

I wasn't able to produce the issue.

Guess I just got lucky.

barjunk
Posts: 42
Joined: Thu Jun 19, 2014 2:51 am
Country: -

Re: Companion 2.1.7 wont read from Taranis

Post by barjunk » Tue Jul 12, 2016 4:58 am

So since my bootloader says 2.0.9, did I miss something when I updated the radio firmware?

User avatar
Kilrah
Posts: 9560
Joined: Sat Feb 18, 2012 6:56 pm
Country: Switzerland

Re: Companion 2.1.7 wont read from Taranis

Post by Kilrah » Tue Jul 12, 2016 9:30 am

No you didn't miss anything, a normal firmware upgrade does not touch the bootloader. If you want to update that you have to do it separately from OpenTX's SD card browser.

Post Reply

Return to “companion9x”