ELI5: Need help flashing er9x but "target doesnt answer"

Where to find parts? Refactoring your entire transmitter, new cases? Sticks etc..
Post Reply
dinosawr
Posts: 6
Joined: Tue Nov 18, 2014 6:06 am
Country: -

ELI5: Need help flashing er9x but "target doesnt answer"

Post by dinosawr » Tue Nov 18, 2014 6:53 am

Me = super newb just assembling a quadcopter from parts for the first time using online tutorials. They were straightforward enough, but unfortunately didnt mention anything about er9x, so now I'm here.. Please keep your answers reaaaaaally simple because I don't know much about programming or eePe. Thanks in advance for your help.

I just installed a smartie parts solderless programmer board rev 2.4 into a turnigy remote. I had to manually install a driver to get the USB connection to be recognized. Now I'm using eePe to flash er9x onto the transmitter. When I try to write flash to the transmitter, I get this message:
=================================================================================
Started AVRDUDE
C:/Program Files (x86)/eePe/avrdude.exe -c usbasp -p m64 -U eeprom:r:C:/Users/Coulter/AppData/Local/Temp/eebackup.hex:i
avrdude.exe: error: programm enable: target doesn't answer. 1
avrdude.exe: initialization failed, rc=-1
Double check connections and try again, or use -F to override
this check.
avrdude.exe done. Thank you.
AVRDUDE done - exit code 1
==================================================================================

The transmitter is on and I'm just following these instructions https://www.youtube.com/watch?v=OuO5JD_7LVo

I get the impression that the installation of the programmer board is more delicate that it seems. Is it possible that I put the screws and spacers in incorrectly? I mean, they're just screws.. It seemed fine when I closed it all up. How would I know if that's the problem. Don't fixate on that too much because this is just paranoid me talking.. unless you really think it might be the problem.

Again, please keep your answers easy to understand for a first timer. Thank you very much for your assistance.
Last edited by dinosawr on Thu Nov 20, 2014 6:41 am, edited 1 time in total.

User avatar
jhsa
Posts: 17815
Joined: Tue Dec 27, 2011 5:13 pm
Country: Germany

Re: ELI5: Need help flashing er9x but "target doesnt answer"

Post by jhsa » Tue Nov 18, 2014 7:16 am

Please check for misaligned pins on the SP board and try to clean the little pads on the tx's mainboard. Sometimes there is just a bad connection.

João
My er9x/Ersky9x/eepskye Video Tutorials
https://www.youtube.com/playlist?list=PL5uJhoD7sAKidZmkhMpYpp_qcuIqJXhb9

Donate to Er9x/Ersky9x:
https://www.paypal.com/cgi-bin/webscr?cmd=_s-xclick&hosted_button_id=YHX43JR3J7XGW

dinosawr
Posts: 6
Joined: Tue Nov 18, 2014 6:06 am
Country: -

Re: ELI5: Need help flashing er9x but "target doesnt answer"

Post by dinosawr » Thu Nov 20, 2014 6:34 am

Yup. I'm an idiot. Didn't install the spacers correctly. Thanks a bunch!

User avatar
jhsa
Posts: 17815
Joined: Tue Dec 27, 2011 5:13 pm
Country: Germany

Re: ELI5: Need help flashing er9x but "target doesnt answer"

Post by jhsa » Thu Nov 20, 2014 11:28 am

Hey, don't steal my job here ;) I'm normally the idiot here, and there's no space for two. :mrgreen: mrgreen:

Glad you got it working though.. Well done. ;)

João
My er9x/Ersky9x/eepskye Video Tutorials
https://www.youtube.com/playlist?list=PL5uJhoD7sAKidZmkhMpYpp_qcuIqJXhb9

Donate to Er9x/Ersky9x:
https://www.paypal.com/cgi-bin/webscr?cmd=_s-xclick&hosted_button_id=YHX43JR3J7XGW

Post Reply

Return to “Hardware Mods”