Installation of MegaSound 9X

Where to find parts? Refactoring your entire transmitter, new cases? Sticks etc..
User avatar
LTMNO
Posts: 1047
Joined: Fri Nov 30, 2012 9:31 pm
Country: Canada
Location: Toronto, Canada

Re: Installation of MegaSound 9X

Post by LTMNO » Sat Dec 05, 2015 8:11 pm

Hmm, the SP Basic.
Yeah that is the whole reason for this discussion, I apoligize for not being clear... I was not able to program and or power on the radio to see anything other than 'Switch Error!'

I figure I couldn't program until that was resolved...
So all is well and maybe my programmer is not good?
Custom 9x with M64/Telemetry Mod

User avatar
LTMNO
Posts: 1047
Joined: Fri Nov 30, 2012 9:31 pm
Country: Canada
Location: Toronto, Canada

Re: Installation of MegaSound 9X

Post by LTMNO » Sat Dec 05, 2015 8:56 pm

p.s. Confirmed 5V at all push button signal wires.
Custom 9x with M64/Telemetry Mod

User avatar
LTMNO
Posts: 1047
Joined: Fri Nov 30, 2012 9:31 pm
Country: Canada
Location: Toronto, Canada

Re: Installation of MegaSound 9X

Post by LTMNO » Sat Dec 05, 2015 9:42 pm

Well, the good news, I was able to get connected and program the radio, well I am backing it up right now..
Apparently the SP Basic is faulty...
I can connect by direct wire via soldering to pads without a solder-less solution.
Custom 9x with M64/Telemetry Mod

User avatar
LTMNO
Posts: 1047
Joined: Fri Nov 30, 2012 9:31 pm
Country: Canada
Location: Toronto, Canada

Re: Installation of MegaSound 9X

Post by LTMNO » Sat Dec 05, 2015 10:11 pm

Alright, successfully updated radio firmware, unfortunately lots not working at the moment with the radio THR Switch is ON and stick is dead including TRIM for Throttle that is...
Too much to write about as its late right now... I will post tomorrow afternoon my finding...
Will have to let Steven know that this particular SP Basic board was a dud faulty...
Last edited by LTMNO on Tue Dec 08, 2015 12:31 am, edited 1 time in total.
Custom 9x with M64/Telemetry Mod

User avatar
LTMNO
Posts: 1047
Joined: Fri Nov 30, 2012 9:31 pm
Country: Canada
Location: Toronto, Canada

Re: Installation of MegaSound 9X

Post by LTMNO » Sun Dec 06, 2015 3:24 pm

What is the latest MegaSound9x Firmwares?

I have found this on the thread earlier on...

(posted March16)

combinedSerial.hex
amod_last.hex
amod_last16.hex
amod_lastSer.hex
amod_lastSer16.hex

I think v4 is what it was shipped with...
I am going to use er9x and serial for update SD card.. but still use the LCD lines for connection.

Thanks.
Custom 9x with M64/Telemetry Mod


User avatar
MikeB
9x Developer
Posts: 15619
Joined: Tue Dec 27, 2011 1:24 pm
Country: -
Location: Poole, Dorset, UK

Re: Installation of MegaSound 9X

Post by MikeB » Sun Dec 06, 2015 3:38 pm

If you add the extra serial connections, and move the trim switch connections, you get the benefit of being able to backup and restore models to/from the SD card on the MegaSound.

The files with "16" in the filename are for a ATMEGA168 processor.
The combined.hex includes the bootloader and needs to be flashed using a programmer.

I think you will just want amod_last.hex. amod_lastSer.hex is for if you have the serial only connection.

Mike.
ersky9x/er9x developer
The difficult we do immediately,
The impossible takes a little longer!

User avatar
jhsa
Posts: 17815
Joined: Tue Dec 27, 2011 5:13 pm
Country: Germany

Re: Installation of MegaSound 9X

Post by jhsa » Sun Dec 06, 2015 4:00 pm

MikeB wrote:If you add the extra serial connections, and move the trim switch connections, you get the benefit of being able to backup and restore models to/from the SD card on the MegaSound.
Mike, I believe Pino will use openTX on this radio.. If so, serial and Backup/Restore is NOT supported.
The files with "16" in the filename are for a ATMEGA168 processor.
I do believe this file is for the arduino with m328, 5V at 16Mhz. At least this is the name of the file posted on the ArduVoice thread.

viewtopic.php?f=5&t=6831

João
My er9x/Ersky9x/eepskye Video Tutorials
https://www.youtube.com/playlist?list=PL5uJhoD7sAKidZmkhMpYpp_qcuIqJXhb9

Donate to Er9x/Ersky9x:
https://www.paypal.com/cgi-bin/webscr?cmd=_s-xclick&hosted_button_id=YHX43JR3J7XGW

User avatar
LTMNO
Posts: 1047
Joined: Fri Nov 30, 2012 9:31 pm
Country: Canada
Location: Toronto, Canada

Re: Installation of MegaSound 9X

Post by LTMNO » Sun Dec 06, 2015 7:26 pm

Hi Mike, I have added the serial connection and have used them for the Backup/Restore on my other board... so that works.. without moving the LCD off the MegaSound right... as in, i have that working on my other radio. I just have alot of hot glue by accident on the trim switch lines... i can work taking it off.. but if i can do that without just freeing the LCD lines.. then I am fine with that.. but i can do it if you think i should.

My other radio has all that working while still using LCD lines...

The jury is out on the Firmware on this... I really want this radio to have OpenLRS and Telemetry for my APM(Mavlink) that is the Goal. I should everything work for both.. I have the hardware.
Custom 9x with M64/Telemetry Mod

User avatar
LTMNO
Posts: 1047
Joined: Fri Nov 30, 2012 9:31 pm
Country: Canada
Location: Toronto, Canada

Re: Installation of MegaSound 9X

Post by LTMNO » Sun Dec 06, 2015 7:29 pm

Joao, your link is to ArduVoice... not MegaSound... are they the same.?
Custom 9x with M64/Telemetry Mod

User avatar
jhsa
Posts: 17815
Joined: Tue Dec 27, 2011 5:13 pm
Country: Germany

Re: Installation of MegaSound 9X

Post by jhsa » Sun Dec 06, 2015 7:51 pm

The arduvoice is basically a MegaSound but is built using an arduino board running on 5V and at 16Mhz. I posted that link so Mike can see that the file has the same name..

João
My er9x/Ersky9x/eepskye Video Tutorials
https://www.youtube.com/playlist?list=PL5uJhoD7sAKidZmkhMpYpp_qcuIqJXhb9

Donate to Er9x/Ersky9x:
https://www.paypal.com/cgi-bin/webscr?cmd=_s-xclick&hosted_button_id=YHX43JR3J7XGW

User avatar
LTMNO
Posts: 1047
Joined: Fri Nov 30, 2012 9:31 pm
Country: Canada
Location: Toronto, Canada

Re: Installation of MegaSound 9X

Post by LTMNO » Sun Dec 06, 2015 8:10 pm

ah got it.. I just repaired the Roll Stick.. just checking to see why the THR is not working...
That should not be affected... just the THR Switch... right?

EDIT:
just repaired the THR Stick as well.. I had a wire fray contacting the Signal which gave it 100%... all better now...
So sticks are good.. Everything working but the THR Switch is still alarming.

Investigating now...
Last edited by LTMNO on Sun Dec 06, 2015 8:54 pm, edited 1 time in total.
Custom 9x with M64/Telemetry Mod

User avatar
MikeB
9x Developer
Posts: 15619
Joined: Tue Dec 27, 2011 1:24 pm
Country: -
Location: Poole, Dorset, UK

Re: Installation of MegaSound 9X

Post by MikeB » Sun Dec 06, 2015 8:50 pm

I'm trying to get round to adding mavlink telemetry to ersky9x. The main problem is I don't have anything to test it with.
Any suggestions on the minimum hardware I would need to get a mavlink telemetry data source?

Mike.
ersky9x/er9x developer
The difficult we do immediately,
The impossible takes a little longer!

User avatar
jhsa
Posts: 17815
Joined: Tue Dec 27, 2011 5:13 pm
Country: Germany

Re: Installation of MegaSound 9X

Post by jhsa » Sun Dec 06, 2015 8:54 pm

Mike, I think openTX supports it? Would it help if you had a look at its code?

João
My er9x/Ersky9x/eepskye Video Tutorials
https://www.youtube.com/playlist?list=PL5uJhoD7sAKidZmkhMpYpp_qcuIqJXhb9

Donate to Er9x/Ersky9x:
https://www.paypal.com/cgi-bin/webscr?cmd=_s-xclick&hosted_button_id=YHX43JR3J7XGW

User avatar
LTMNO
Posts: 1047
Joined: Fri Nov 30, 2012 9:31 pm
Country: Canada
Location: Toronto, Canada

Re: Installation of MegaSound 9X

Post by LTMNO » Sun Dec 06, 2015 9:19 pm

Hi Mike, that would be golden!
Well to start you would need a APM.
http://www.banggood.com/DYS-Mini-APM-Fl ... 77560.html
This will give you all the wonderful telemetry data you would produce from an APM FC.
There is a Telemetry Port, UART that will output all the APM Telemetry in Mavlink format.
I have a few, I will send you one to further the cause, say no more...
PM me your address... I will post it tomorrow.
Custom 9x with M64/Telemetry Mod

User avatar
LTMNO
Posts: 1047
Joined: Fri Nov 30, 2012 9:31 pm
Country: Canada
Location: Toronto, Canada

Re: Installation of MegaSound 9X

Post by LTMNO » Sun Dec 06, 2015 9:25 pm

oOn a different note, I am going to put the serial mod in place..
I was talking to Jaoa, I think I have the setup down....

M128 MegaSound
Pin28 --> Pad7
Pin27 --> Pad8
D0(Pin2) --> Pin2 (from Trim input (white wire from position 7)
D1(Pin3) --> Pin3 (from Trim input (violet wire from position 9)

Sound right?
Last edited by LTMNO on Sun Dec 06, 2015 10:08 pm, edited 1 time in total.
Custom 9x with M64/Telemetry Mod

User avatar
MikeB
9x Developer
Posts: 15619
Joined: Tue Dec 27, 2011 1:24 pm
Country: -
Location: Poole, Dorset, UK

Re: Installation of MegaSound 9X

Post by MikeB » Sun Dec 06, 2015 10:02 pm

João: Yes, I've seen that code,I intend to base my implementation on it. That code itself was, I think, copied from the Teensy mavlink to frsky project.

LTMNO: If you really have one spare, then thanks.

Mike.
ersky9x/er9x developer
The difficult we do immediately,
The impossible takes a little longer!

User avatar
jhsa
Posts: 17815
Joined: Tue Dec 27, 2011 5:13 pm
Country: Germany

Re: Installation of MegaSound 9X

Post by jhsa » Sun Dec 06, 2015 11:15 pm

LTMNO wrote: I have a few, I will send you one to further the cause, say no more...
PM me your address... I will post it tomorrow.
Pino, you're Gold my friend :)

João
My er9x/Ersky9x/eepskye Video Tutorials
https://www.youtube.com/playlist?list=PL5uJhoD7sAKidZmkhMpYpp_qcuIqJXhb9

Donate to Er9x/Ersky9x:
https://www.paypal.com/cgi-bin/webscr?cmd=_s-xclick&hosted_button_id=YHX43JR3J7XGW

User avatar
LTMNO
Posts: 1047
Joined: Fri Nov 30, 2012 9:31 pm
Country: Canada
Location: Toronto, Canada

Re: Installation of MegaSound 9X

Post by LTMNO » Mon Dec 07, 2015 1:08 am

@Joao, thanks.... ;-)
@Mike, my pleasure...

Update to the efforts here... we have voice!
I was able to get the serial to work this new way, I mapped the lines as mentioned above. I powered it on and I am in business.
The first message was ALERT! then the Switch Error for THR... not sure, I will double check my wiring on that one.
At a first glance all is working now. I will play and test the file transfer and such... but that should be fine. I still have to wire in the Diode and the FTDI setup for serial.

I suspect the code that was on the MegaSound or 9x didn't support the LCD lines, they were hooked correctly... The minute the Serial Interface was connected to D1/D2, we had voice.

Speaker is wired like so...
Image

Before:

Image


After:

Image
Custom 9x with M64/Telemetry Mod

User avatar
LTMNO
Posts: 1047
Joined: Fri Nov 30, 2012 9:31 pm
Country: Canada
Location: Toronto, Canada

Re: Installation of MegaSound 9X

Post by LTMNO » Mon Dec 07, 2015 1:27 am

Another EDIT> It all works... The THR Switch was fine, just a wire was loose on the connector.
I tested the Backup and Restore... Golden... everything is A-OKAY!

Thank-You!
Custom 9x with M64/Telemetry Mod

User avatar
jhsa
Posts: 17815
Joined: Tue Dec 27, 2011 5:13 pm
Country: Germany

Re: Installation of MegaSound 9X

Post by jhsa » Mon Dec 07, 2015 2:37 am

great ;) :)

João
My er9x/Ersky9x/eepskye Video Tutorials
https://www.youtube.com/playlist?list=PL5uJhoD7sAKidZmkhMpYpp_qcuIqJXhb9

Donate to Er9x/Ersky9x:
https://www.paypal.com/cgi-bin/webscr?cmd=_s-xclick&hosted_button_id=YHX43JR3J7XGW

User avatar
LTMNO
Posts: 1047
Joined: Fri Nov 30, 2012 9:31 pm
Country: Canada
Location: Toronto, Canada

Re: Installation of MegaSound 9X

Post by LTMNO » Mon Dec 07, 2015 4:16 am

;-)
Just as I was wrapping it all up... I realized that I was going to pull the Miso/Mosi from the SP Basic pads... now I have to grab it from the Programming wire.. RRRRRGGGGGHHHH!
I forgot about the Telemetry... lol
Its been a long week/end...
Custom 9x with M64/Telemetry Mod

User avatar
jhsa
Posts: 17815
Joined: Tue Dec 27, 2011 5:13 pm
Country: Germany

Re: Installation of MegaSound 9X

Post by jhsa » Mon Dec 07, 2015 10:07 am

It happens.. :)

João
My er9x/Ersky9x/eepskye Video Tutorials
https://www.youtube.com/playlist?list=PL5uJhoD7sAKidZmkhMpYpp_qcuIqJXhb9

Donate to Er9x/Ersky9x:
https://www.paypal.com/cgi-bin/webscr?cmd=_s-xclick&hosted_button_id=YHX43JR3J7XGW

User avatar
LTMNO
Posts: 1047
Joined: Fri Nov 30, 2012 9:31 pm
Country: Canada
Location: Toronto, Canada

Re: Installation of MegaSound 9X

Post by LTMNO » Mon Dec 07, 2015 10:00 pm

;-)
So, case is closed... connected the telemetry, haven't tested that yet... I will when I get my oLRS going... need more time.
Finished the Case and mounts for the Serial and ISP.

Wiring
Image

USBASP/SERIAL Cover
Image

I cut the notches in the case and put this cover on to make it look better.

Now, solve the SD Card update with Serial for Voice Files... then its all done. Posted the problem on er9x Development Thread....

viewtopic.php?f=5&t=2&p=107016#p107016

Image
Custom 9x with M64/Telemetry Mod

User avatar
HC1969
Posts: 421
Joined: Wed Dec 28, 2011 8:47 am
Country: Hungary
Location: Istvan Magi
Contact:

Re: Installation of MegaSound 9X

Post by HC1969 » Thu Feb 18, 2016 7:18 pm

The lates MegaSound 9X board available on eBay:
http://www.ebay.com/itm/111888607101?ss ... 1558.l2649
Image
http://rc.emiter.hu/ (MegaSound 9X, GCL-2, FrSky-RSSI-DAC, etc.) Keress fel!

Post Reply

Return to “Hardware Mods”