9x with DHT (intermittent RSSI/A1 and no telemetry)

All mods related to the frsky telemetry series of the firmware
Post Reply
yaoweic
Posts: 10
Joined: Wed Mar 30, 2016 6:54 am
Country: United Kingdom

9x with DHT (intermittent RSSI/A1 and no telemetry)

Post by yaoweic » Wed Mar 30, 2016 6:38 pm

Hi all,
I'm an RC newbie, was recommended this forum regarding my issue with my 9x, hope I can get some advice.
I modified a Turnigy9x similar to what folks did to allow OpenTx to be flashed. I am running on OpenTx-9x 128-2.0.19 with FrSky mod.
I modified a DHT diy module to allow RSSI and A1 signal to be displayed on the Turnigy9x screen. Basically I followed the method which did not require a level converter, see attached photos.
I am also using a FrSky D4R-ii receiver on PPM.

Because this is my first radio, after searching in forums, I found out that the Rx/Tx and A1 values from the D4R-ii is meant to display instantaneously after the radio & receiver are bound. However mine is intermittent, sometimes it comes through sometimes it does not. Most of the time it doesnt.
On the DHT module, I followed a method which bypasses the Sipex 3232EE chip, therefore not needing to use a level converter.

Note that I also have issues displaying telemetry such as Cell, Cels, AccX, Y and Z. I use Cleanflight 1.11 and inverted the telemetry signal using 'set telemetry_inversion = ON'. The Rx/Gnd connection from D4R-ii is connected to the Naze32 Rev6 Txi/Gnd connections.

My question is, did I damage the DHT module with my hack? I do not think I damaged the motherboard since I am able to run on OpenTx. The Rx/Tx connection to MISO/MOSI I believe is just for display?
Do I have a faulty D4R-ii since it has issues with telemetry as well? When I connect signal pin 2 (running on PPM) to my OSD, the entire OSD disappears.

Hope I get pointed in the right direction, thanks.
Attachments
DSC02777.JPG
DSC02778.JPG

Greebo
Posts: 63
Joined: Sat Jun 16, 2012 11:12 am
Country: Australia
Location: NSW

Re: 9x with DHT (intermittent RSSI/A1 and no telemetry)

Post by Greebo » Fri Apr 01, 2016 9:35 am

What is under the heat shrink in that second photo? Are you absolutely sure there's no solder bridge between the two joints at the bottom of that second picture?

How is the module connected to the 9x?

yaoweic
Posts: 10
Joined: Wed Mar 30, 2016 6:54 am
Country: United Kingdom

Re: 9x with DHT (intermittent RSSI/A1 and no telemetry)

Post by yaoweic » Fri Apr 01, 2016 11:59 am

Hi Greebo! the heat shrinks basically cover 2x 2.2kohms resistors. The smaller heat shrink is just to cover the resistor leg a little more to avoid contact.
I've checked to the best of my ability using a multimeter, there's no connectivity between them.
The module is connected to the back board of 9x with ppm, positive and negative connections. The Rx and Tx are connected to the MISO, MOSI connections. Ie. the opposite Tx and Rx. I'm just curious if connection is incorrect would it cause an intermittent output of RSSI, thought it basically just wouldn't work.

yaoweic
Posts: 10
Joined: Wed Mar 30, 2016 6:54 am
Country: United Kingdom

Re: 9x with DHT (intermittent RSSI/A1 and no telemetry)

Post by yaoweic » Sat Apr 09, 2016 8:53 am

Just an update to this thread.
I bought a new DHT DIY module and a new D4R-ii receiver. I installed the new DHT DIY module with a FrSky lite this time, basically instead of bypassing the SIPEX module, I used the FrSky Lite to convert the signal again. This time on both D4R-ii receivers the Tx, Rx and A1 values came in instantaneously when the D4R-ii is powered up. However I still cannot see telemetry data back to my radio on both receivers. To clarify these are AccX, Y, Z and Cels/Cell values. So either my Cleanflight is not configured correctly (I already executed 'set telemetry_inversion = ON') or my wiring is incorrect. The serial data port on D4R-ii is connected to the TXI and Gnd pins of my Naze32 Rev6. I armed the quad and still no values on my radio transmitter screen.
Both receivers also caused issues when I was connecting Channel 2 RSSI output to my MINIMOSD MICRO basically screws it up. I think this is just a configuration issue which I have to find the right way of working.

Any ideas are appreciated. Thanks

Greebo
Posts: 63
Joined: Sat Jun 16, 2012 11:12 am
Country: Australia
Location: NSW

Re: 9x with DHT (intermittent RSSI/A1 and no telemetry)

Post by Greebo » Sat Apr 09, 2016 12:16 pm

If you're getting RSSI and A1 values then the telemetry on the 9x/DHT and D4R-ii are all working. The issue is going to be either the wiring from the Rx to the FC or the configuration in cleanflight.

Which wire(s) are connected from the D4R-II to the NAZE32? The receiver comes with a plug with 4 wires in it, I removed the red and the white wires from the connector that plugs into the D4R-II (leaving just the green and black wires) and connected green (which is Rx on the D4R-II) to Telemetry Tx and black (which is Gnd on the D4R-II) to Telemetry Gnd on my NAZE32 R6.

I then just enabled Telemetry (FrSky) on UART1 in the cleanflight configurator and checked that telemetry_inversion was on.

I can't help you with getting RSSI Output into cleanflight as I've not done that.


yaoweic
Posts: 10
Joined: Wed Mar 30, 2016 6:54 am
Country: United Kingdom

Re: 9x with DHT (intermittent RSSI/A1 and no telemetry)

Post by yaoweic » Sat Apr 09, 2016 7:09 pm

Hi Greebo, I have the same wire connections as yours. Rx from D4R-ii is connected to TXI on Naze32 Rev6. Gnd to Gnd.
I did not enable telemetry on UART1, frankly this is the first time I've heard of that being required. I enabled telemetry on Cleanflight and set telemetry inversion being ON.

I will give it a go on UART1, what is your baud rate and what should it be matched with?
Attachments
DSC02709.JPG
D4R-ii

yaoweic
Posts: 10
Joined: Wed Mar 30, 2016 6:54 am
Country: United Kingdom

Re: 9x with DHT (intermittent RSSI/A1 and no telemetry)

Post by yaoweic » Sat Apr 09, 2016 8:14 pm

Hi Greebo, glad to report i've just triggered FrSky telemetry on UART1 while maintaining the same wiring and it has worked. Baud rate is on AUTO. Can you explain to me why I need to trigger FrSky on UART1 because i'm not connected to UART1.
Thanks

Greebo
Posts: 63
Joined: Sat Jun 16, 2012 11:12 am
Country: Australia
Location: NSW

Re: 9x with DHT (intermittent RSSI/A1 and no telemetry)

Post by Greebo » Sat Apr 09, 2016 11:33 pm

UART1 is where the "Telemetry" Tx and Gnd pins are physically connected on the NAZE32 Rev6 (and probably previous versions), so actually, you are connected to UART1, just on different pins.

Glad you got it all sorted!

Post Reply

Return to “FRSky Telemetry Mods”

Who is online

Users browsing this forum: No registered users and 1 guest