T9x FrSky telemetry mod fail. Gibberish filled/blank screen

All mods related to the frsky telemetry series of the firmware
Post Reply
manny34711
Posts: 13
Joined: Fri Oct 10, 2014 10:27 pm
Country: -

T9x FrSky telemetry mod fail. Gibberish filled/blank screen

Post by manny34711 » Sun Oct 12, 2014 5:25 am

So I purchased a T9X and a FrSky DJT module w/ a D8R-II Plus RX to get optimal performance out of the T9X. I did tons of research before I attempted the mod. I read guides from RCHACKER, Oscar Liang and the openWiki for the T9x, I even watched a few YouTube videos. After about a week of researching I decided to give it a try.

I flashed the ER9X using an Arduino UNO successfully. I followed the guide on Oscar Liang's blog ( http://blog.oscarliang.net/turnigy-9...modifications/ ). I then proceeded to his next guide on getting FrSky working w/ the T9X as well as his telemetry mod guide using the trace cutting method found here ( http://blog.oscarliang.net/turnigy-9x-advance-mod/ ).

I chose to go with Method 2 on his guide which involved cutting the traces on the board then routing wires from the base of the resistors to pins 41 and 42 on the AtMega chip. Before I powered everything I used my multimeter to make sure I wasn't shorting anything and everything seemed fine... until I turned it on.

When it turns on I get a nice working transmitter showing the ER9X splash screen. I'm able to browse the menus and even do some calibrating (for about 2 minutes). After a few minutes the screen starts glitching and you start seeing random characters and pixels all over the screen. The LCD gets more and more cluttered until it finally shuts off completely. I'm able to still press buttons and hear beeps when I hold menu buttons etc but no screen. If i turn it off and turn it back on I still get nothing. It is only if I leave it off for a while then turn it on when I'm able to see anything again.

To troubleshoot: I unsoldered all of the cables (including the ones used for flashing the T9X) and re soldered just the 2 cables running from the base of the 2 resistors running to pins 41 and 42. Same results.

My second troubleshooting attempt I removed all cables again but this time I "undid" the trace cuts by running a wire from the solder pads directly to the base resistors as if I never made the trace cuts. Same results.

3rd troubleshooting technique was using an external 5V power source from my arduino to the custom soldered wires that I used to flash. Same results. I've been reading similar problems around the internet from users to had completely non working screens but I've never came across one that has issues like the ones I'm currently having. Does anyone know what I should test for more troubleshooting? I have good soldering skills and a multimeter. I have access to scopes in my EE labs too. Any specific resistors or voltage regulators I should test?

This video is a recording of what the problem is: https://www.youtube.com/watch?v=A5Sg2P8gTgo
It will work fine for about 2 minutes before it just freezes. After I reboot it, it gets distorted as shown in the video.

Has anyone seen this before?
Last edited by manny34711 on Mon Oct 13, 2014 7:39 am, edited 1 time in total.

User avatar
Kilrah
Posts: 9229
Joined: Sat Feb 18, 2012 6:56 pm
Country: Switzerland

Re: T9x FrSky telemetry mod fail. Gibberish filled or blank

Post by Kilrah » Sun Oct 12, 2014 6:03 am

Did you actually use the radio on the stock firmware it came with for a while? Hopefully yes and you didn't see the same issue, would eliminate the simple issue of a defective LCD.

ReSt
Posts: 1419
Joined: Tue Dec 27, 2011 11:34 pm
Country: -

Re: T9x FrSky telemetry mod fail. Gibberish filled or blank

Post by ReSt » Sun Oct 12, 2014 7:37 am

Is there any chip that gets more than warm ?

Reinhard

manny34711
Posts: 13
Joined: Fri Oct 10, 2014 10:27 pm
Country: -

Re: T9x FrSky telemetry mod fail. Gibberish filled or blank

Post by manny34711 » Mon Oct 13, 2014 12:39 am

Kilrah wrote:Did you actually use the radio on the stock firmware it came with for a while? Hopefully yes and you didn't see the same issue, would eliminate the simple issue of a defective LCD.
Yes I used it a bit but just navigating the menus and calibrating. Used it for a good hour to so.

manny34711
Posts: 13
Joined: Fri Oct 10, 2014 10:27 pm
Country: -

Re: T9x FrSky telemetry mod fail. Gibberish filled or blank

Post by manny34711 » Mon Oct 13, 2014 12:42 am

ReSt wrote:Is there any chip that gets more than warm ?

Reinhard

I'm not sure but that same thought crossed my mind :/


User avatar
MikeB
9x Developer
Posts: 14958
Joined: Tue Dec 27, 2011 1:24 pm
Country: -
Location: Poole, Dorset, UK

Re: T9x FrSky telemetry mod fail. Gibberish filled/blank scr

Post by MikeB » Mon Oct 13, 2014 8:38 am

I would check the connections between the processor and the LCD. Because the processor runs at 5 volts, and the LCD at 3.3, every connection has a 5K1 and a 10K resistor in it.
The 8 data lines are from pins 44 to 51, the control lines are from pins 36 to 40.
In particular, I'd check the connection to pin 40 of the processor since this is right beside a pin you used for the mod. This signal is the main control strobe for the LCD.

Mike.
ersky9x/er9x developer
The difficult we do immediately,
The impossible takes a little longer!

manny34711
Posts: 13
Joined: Fri Oct 10, 2014 10:27 pm
Country: -

Re: T9x FrSky telemetry mod fail. Gibberish filled/blank scr

Post by manny34711 » Mon Oct 13, 2014 9:17 am

MikeB wrote:I would check the connections between the processor and the LCD. Because the processor runs at 5 volts, and the LCD at 3.3, every connection has a 5K1 and a 10K resistor in it.
The 8 data lines are from pins 44 to 51, the control lines are from pins 36 to 40.
In particular, I'd check the connection to pin 40 of the processor since this is right beside a pin you used for the mod. THis signal is the main control strobe for the LCD.

Mike.
Thanks Mike, I'll give it a shot on Tuesday and let you know the results!

manny34711
Posts: 13
Joined: Fri Oct 10, 2014 10:27 pm
Country: -

Re: T9x FrSky telemetry mod fail. Gibberish filled/blank scr

Post by manny34711 » Wed Oct 15, 2014 6:06 am

MikeB wrote:I would check the connections between the processor and the LCD. Because the processor runs at 5 volts, and the LCD at 3.3, every connection has a 5K1 and a 10K resistor in it.
The 8 data lines are from pins 44 to 51, the control lines are from pins 36 to 40.
In particular, I'd check the connection to pin 40 of the processor since this is right beside a pin you used for the mod. This signal is the main control strobe for the LCD.

Mike.

Hey Mike, I got back to doing some testing. I tested pin 40 and it was isolated from pins 41 and 39 as it should be. The trace goes well to the resistor above. The LCD strip cable is plugged in nicely. The 78L05 voltage regulator is properly feeding the 3.3V to the LCD strip. I'm starting to thing that the Atmega64 is what is damaged due to excessive heat applied during soldering.

User avatar
jhsa
Posts: 17202
Joined: Tue Dec 27, 2011 5:13 pm
Country: Germany

Re: T9x FrSky telemetry mod fail. Gibberish filled/blank scr

Post by jhsa » Wed Oct 15, 2014 7:38 am

Are you sure that is the 78L05 that is supplying the 3.3V? That one sbould be supplying 5V to the chip. The other one to the left should supply 3.3V :)

João
My er9x/Ersky9x/eepskye Video Tutorials
https://www.youtube.com/playlist?list=PL5uJhoD7sAKidZmkhMpYpp_qcuIqJXhb9

Donate to Er9x/Ersky9x:
https://www.paypal.com/cgi-bin/webscr?cmd=_s-xclick&hosted_button_id=YHX43JR3J7XGW

manny34711
Posts: 13
Joined: Fri Oct 10, 2014 10:27 pm
Country: -

Re: T9x FrSky telemetry mod fail. Gibberish filled/blank scr

Post by manny34711 » Wed Oct 15, 2014 9:18 am

jhsa wrote:Are you sure that is the 78L05 that is supplying the 3.3V? That one sbould be supplying 5V to the chip. The other one to the left should supply 3.3V :)

João

Ah, yeah you're right! I just verified and it is supplying 3.3v to the lcd. I'm so convinced it's the mega64

User avatar
MikeB
9x Developer
Posts: 14958
Joined: Tue Dec 27, 2011 1:24 pm
Country: -
Location: Poole, Dorset, UK

Re: T9x FrSky telemetry mod fail. Gibberish filled/blank scr

Post by MikeB » Wed Oct 15, 2014 9:40 am

You could try cooling the M64. Run the Tx until the display just starts to go wrong, then try making the M64 centre a bit damp, using a damp finger. The evaporation of the damp cools the chip a bit. See if the display comes back OK for a while. Keep the M64 slightly damp to keep it cooling.

Mike.
ersky9x/er9x developer
The difficult we do immediately,
The impossible takes a little longer!

manny34711
Posts: 13
Joined: Fri Oct 10, 2014 10:27 pm
Country: -

Re: T9x FrSky telemetry mod fail. Gibberish filled/blank scr

Post by manny34711 » Thu Oct 16, 2014 12:10 am

MikeB wrote:You could try cooling the M64. Run the Tx until the display just starts to go wrong, then try making the M64 centre a bit damp, using a damp finger. The evaporation of the damp cools the chip a bit. See if the display comes back OK for a while. Keep the M64 slightly damp to keep it cooling.

Mike.
While I didn't use the damp finger method for cooling, I did end up putting a small fan blowing directly on the chip. It's hard to say if it made a difference or not. I just ordered a new M64 and will try to replace the old one. I will post the results once that happens. Until then, feel free to spit out troubleshooting ideas I can try in the meantime. This is so frustrating :/

User avatar
jhsa
Posts: 17202
Joined: Tue Dec 27, 2011 5:13 pm
Country: Germany

Re: T9x FrSky telemetry mod fail. Gibberish filled/blank scr

Post by jhsa » Thu Oct 16, 2014 6:15 am

If you are going to attempt to replace it, you should have gone for the atmega128 or the 2561.. ;)
More flash memory, more (double) eeprom, and the last one more ram too..
It doesn't make sense replacing with the same.

João
My er9x/Ersky9x/eepskye Video Tutorials
https://www.youtube.com/playlist?list=PL5uJhoD7sAKidZmkhMpYpp_qcuIqJXhb9

Donate to Er9x/Ersky9x:
https://www.paypal.com/cgi-bin/webscr?cmd=_s-xclick&hosted_button_id=YHX43JR3J7XGW

manny34711
Posts: 13
Joined: Fri Oct 10, 2014 10:27 pm
Country: -

Re: T9x FrSky telemetry mod fail. Gibberish filled/blank scr

Post by manny34711 » Tue Oct 21, 2014 5:47 pm

So I ended up buying a new T9X and decided to give the mod another shot. Everything seemed to go well this time, I even completed the backlight mod too. However now I have 1 NEW problem. The old problem of the screen freezing then going out seems to be non existent about 95% of the time. Sometimes it fuzzes up when I switch the THR switch on.

After cutting the correct traces for pins 2 and 3 of the atmel, I wired up the resistors that used to connect to pins 2 and 3 to pins 41 and 42 on top of the mega. I also did the FrSky module mod where I removed the max232 chip and wired some cables from some max232 traces directly to the module pins, etc. I also cut the traces on pins 2 and 5 on the back part of the transmitter and wired them to pins 2 and 3 on the mainboard so everything seems to be wired fine. However, the problem is when I flip the THR and AIL switches, sometimes it glitches, sometimes they work, sometimes they don't. Most of the time they don't work. One may flip the other and vice versa. Any idea what may be the problem? I've made sure I haven't shorted any wires or resistors. I used my multimeter to check on atmel pins 41, and 42, atmel pin 2 and pin 3, t9x backboard pin 2 and pin 5, and the frsky djt mods. They're all connected right and are not making contact with anything it's not supposed to make contact with. The firmware installed is the er9x-frsky.hex latest version. This really sucks considering this is the 2nd one I've had to buy and it's still giving me problems :( I even made sure to do a fast, strong solder to keep the heat down as much as i can :/

manny34711
Posts: 13
Joined: Fri Oct 10, 2014 10:27 pm
Country: -

Re: T9x FrSky telemetry mod fail. Gibberish filled/blank scr

Post by manny34711 » Tue Oct 21, 2014 5:53 pm

Here are some pictures of the board. I removed the 6 cables that were used to flash the board for some better real estate and easier troubleshooting (I've already flashed er9x-frsky). In the picture it may appear that the solder from pin 3 and the resistor right under it are connected but they're not. I've verified using a multimeter. Also, I have 2 resistors in series, in parallel with 2 others to make 450 ohms (I didn't have a 470 ohm resistor).
Attachments
20141021_035742.jpg
20141021_035541.jpg

User avatar
MikeB
9x Developer
Posts: 14958
Joined: Tue Dec 27, 2011 1:24 pm
Country: -
Location: Poole, Dorset, UK

Re: T9x FrSky telemetry mod fail. Gibberish filled/blank scr

Post by MikeB » Tue Oct 21, 2014 6:06 pm

(Maybe post some pictures of the mods you have done.)
Did you cut the traces on BOTH sides of the backboard for pin 2 of the module connector.
I do recommend keeping the RS232 signal from the DJT and adding either a transistor inverter or a MAX232 buffer. This allows for the use of a XJT module instead if required.
Are you testing with the module plugged in, if so, it might be worth trying with it unplugged.
(Is your programmer permanently connected?)

Try reducing things to a minimum by removing the wires for the telemetry from pins 2 and 3 of the processor.

[You posted pictures, and answers, while I was typing!].

Mike.
ersky9x/er9x developer
The difficult we do immediately,
The impossible takes a little longer!

User avatar
jhsa
Posts: 17202
Joined: Tue Dec 27, 2011 5:13 pm
Country: Germany

Re: T9x FrSky telemetry mod fail. Gibberish filled/blank scr

Post by jhsa » Tue Oct 21, 2014 6:17 pm

Something that you might not have done and just came to my mind..

Please go to the general settings, scroll down to hardware and set the option "Frsky Mod Done" to on.

João
My er9x/Ersky9x/eepskye Video Tutorials
https://www.youtube.com/playlist?list=PL5uJhoD7sAKidZmkhMpYpp_qcuIqJXhb9

Donate to Er9x/Ersky9x:
https://www.paypal.com/cgi-bin/webscr?cmd=_s-xclick&hosted_button_id=YHX43JR3J7XGW

manny34711
Posts: 13
Joined: Fri Oct 10, 2014 10:27 pm
Country: -

Re: T9x FrSky telemetry mod fail. Gibberish filled/blank scr

Post by manny34711 » Tue Oct 21, 2014 8:43 pm

jhsa wrote:Something that you might not have done and just came to my mind..

Please go to the general settings, scroll down to hardware and set the option "Frsky Mod Done" to on.

João

Too late now :/ The RC God's must hate me or something. After I removed some hot glue on my DJT module I guess I moved one of the soldered cables inside the DJT module (one of the unused pins) around too much in the process because when I turned on the receiver I saw smoke. I think it came from the DJT module (I don't see any visible signs of damage from the module or T9X mainboard). Anyways, now I try to turn on the T9X (with and without the DJT module) and nothing appears on the screen. Just the blue led backlight from the mod. I checked the voltage regulators on the top left of the mainboard and they're working fine. I also checked the voltage of the TI chip on the bottom left of the mainboard and it's okay too. Looks like I'm on my way to buying my 3rd T9X and my 2nd DJT module...
Last edited by manny34711 on Tue Oct 21, 2014 8:49 pm, edited 1 time in total.

manny34711
Posts: 13
Joined: Fri Oct 10, 2014 10:27 pm
Country: -

Re: T9x FrSky telemetry mod fail. Gibberish filled/blank scr

Post by manny34711 » Tue Oct 21, 2014 8:46 pm

This time around I'd like to take the safest route to doing the mods even if it costs a bit more. What do you guys recommend? Using the smartie parts? Level converters? I see so many different tutorials around its a bit overwhelming.

User avatar
MikeB
9x Developer
Posts: 14958
Joined: Tue Dec 27, 2011 1:24 pm
Country: -
Location: Poole, Dorset, UK

Re: T9x FrSky telemetry mod fail. Gibberish filled/blank scr

Post by MikeB » Tue Oct 21, 2014 9:58 pm

A serious question is: If you purchase another Tx, what about the 9XR-PRO? You may not like the ergonomics of this, but it is $100 instead of $60. This requires NO mods to use with a FrSky DJT (or XJT). The DJT needs an external cable to connect the telemetry (or an internal to the DJT wiring mod), the XjT just plugs in.
This also includes an ARM processor, SD card, voice output, USB connection for flashing and is MUCH more capable. It comes with ersky9x installed. This is the version of er9x but for the ARM processor.

Mike.
ersky9x/er9x developer
The difficult we do immediately,
The impossible takes a little longer!

manny34711
Posts: 13
Joined: Fri Oct 10, 2014 10:27 pm
Country: -

Re: T9x FrSky telemetry mod fail. Gibberish filled/blank scr

Post by manny34711 » Tue Oct 21, 2014 10:09 pm

MikeB wrote:A serious question is: If you purchase another Tx, what about the 9XR-PRO? You may not like the ergonomics of this, but it is $100 instead of $60. This requires NO mods to use with a FrSky DJT (or XJT). The DJT needs an external cable to connect the telemetry (or an internal to the DJT wiring mod), the XjT just plugs in.
This also includes an ARM processor, SD card, voice output, USB connection for flashing and is MUCH more capable. It comes with ersky9x installed. This is the version of er9x but for the ARM processor.

Mike.
Beat you to it lol. Bought a Tanaris. Planning to sell all of my 9x stuff.

User avatar
MikeB
9x Developer
Posts: 14958
Joined: Tue Dec 27, 2011 1:24 pm
Country: -
Location: Poole, Dorset, UK

Re: T9x FrSky telemetry mod fail. Gibberish filled/blank scr

Post by MikeB » Tue Oct 21, 2014 10:44 pm

ersky9x is also available for the Taranis!

Mike.
ersky9x/er9x developer
The difficult we do immediately,
The impossible takes a little longer!

Post Reply

Return to “FRSky Telemetry Mods”

Who is online

Users browsing this forum: No registered users and 4 guests