Companion 2.0.12 can't handle SF with LUA

How to use eePe
Post Reply
frater
Posts: 77
Joined: Sat Aug 30, 2014 11:04 pm
Country: -

Companion 2.0.12 can't handle SF with LUA

Post by frater » Wed Nov 19, 2014 12:55 pm

I assumed the features of Companion and OpenTX went hand in hand, but it now turns out my Model config can't be imported fully if I receive a model on my TX that has a special function with a LUA-script.

I hoped it would only be a problem within Companion and things would be alright for the transmitter, but when I send the model's config back to the transmitter these Special Functions turn into "reserved".

I then have to use my transmitter again to set them to the appropriate LUA-scripts.

Are the devs aware of this or am I doing something wrong?
Are there more things I should be aware of?
How can I publish my eepe if Companion can't handle it?

User avatar
dinamich
Posts: 288
Joined: Mon Apr 01, 2013 1:21 pm
Country: Slovenia
Location: Ljubljana

Re: Companion 2.0.12 can't handle SF with LUA

Post by dinamich » Wed Nov 19, 2014 12:59 pm

Open an issue on github. Thanks

frater
Posts: 77
Joined: Sat Aug 30, 2014 11:04 pm
Country: -

Re: Companion 2.0.12 can't handle SF with LUA

Post by frater » Wed Nov 19, 2014 1:12 pm

OK... did it just now on my phone. The github app on Android is buggy... But I probably have to report that elsewhere :-)

bertrand35
9x Developer
Posts: 2764
Joined: Fri Dec 30, 2011 11:11 pm
Country: -

Re: Companion 2.0.12 can't handle SF with LUA

Post by bertrand35 » Wed Nov 19, 2014 8:11 pm

It should be fixes in nightly builds tonight

frater
Posts: 77
Joined: Sat Aug 30, 2014 11:04 pm
Country: -

Re: Companion 2.0.12 can't handle SF with LUA

Post by frater » Wed Nov 19, 2014 9:55 pm

Where can I download these?


bertrand35
9x Developer
Posts: 2764
Joined: Fri Dec 30, 2011 11:11 pm
Country: -

Re: Companion 2.0.12 can't handle SF with LUA

Post by bertrand35 » Wed Nov 19, 2014 10:19 pm

2.0.13 is out, I fixed it quickly before the release

Post Reply

Return to “eePe”