9xtrem burnt ..how? Don't know but wanna repair...please help

Abach
Posts: 20
Joined: Tue Nov 15, 2016 5:43 pm
Country: -

9xtrem burnt ..how? Don't know but wanna repair...please help

Post by Abach » Tue Nov 15, 2016 5:56 pm

When it s said that 1 picture is worth 1000 words :?: :?:
Attachments
1479232498493-1975218894.jpg

s_mack
Posts: 879
Joined: Thu Dec 29, 2011 6:11 am
Country: -

Re: 9xtrem burnt ..how? Don't know but wanna repair...please help

Post by s_mack » Tue Nov 15, 2016 6:14 pm

Battery plugged in backwards? I'll get you some info shortly on the components involved.

Abach
Posts: 20
Joined: Tue Nov 15, 2016 5:43 pm
Country: -

Re: 9xtrem burnt ..how? Don't know but wanna repair...please help

Post by Abach » Wed Nov 16, 2016 9:14 am

Thanks a lot, the thing is that everything is working except for the tx module bay....have check the othe components which usually burn and they seem to be fine ...the AO3407A is the component I think and control the output for the tx and it gives 3.5 v output so the tx module doesn't work....
Don't know if there is a cut in the trace board ...with the photo ...can u see a cut ? Or changing the mosfet will be enough? ?

User avatar
jhsa
Posts: 17814
Joined: Tue Dec 27, 2011 5:13 pm
Country: Germany

Re: 9xtrem burnt ..how? Don't know but wanna repair...please help

Post by jhsa » Wed Nov 16, 2016 9:54 am

What happened anyway? The module bay mostet being the only component burning because of a battery reversal is a bit strange :)
That looks more like a shorted module, or a miss connection of something to the module bay.
If the battery was reversed, I believe the first mosfet to go would be the radio's soft power one. And that is not damaged? Hnmmm..

João
My er9x/Ersky9x/eepskye Video Tutorials
https://www.youtube.com/playlist?list=PL5uJhoD7sAKidZmkhMpYpp_qcuIqJXhb9

Donate to Er9x/Ersky9x:
https://www.paypal.com/cgi-bin/webscr?cmd=_s-xclick&hosted_button_id=YHX43JR3J7XGW

Abach
Posts: 20
Joined: Tue Nov 15, 2016 5:43 pm
Country: -

Re: 9xtrem burnt ..how? Don't know but wanna repair...please help

Post by Abach » Wed Nov 16, 2016 10:43 am

Hey,thanks for the help....
Not fully sure is not damage, what I did to check its measured the voltage and it's 11.6 on the switch part, where you power the radio.
The thing is that I did not plug a reversal battery, one friend did in his radio and burnt everything but I have plug his TX module on my radio to check if it was working or not....after that without smoke or signals of anything my radio stop working ...I thought it was the battery 'cause one cell was damage and that will make my radio work again.....after that I thought time would solve the electronic Dixies of my radio :D ...and wait a month but after that I got piss off and open to see if it was something wrong and found that burnt.
The 9x original board seem ok without any visual signals of burn,as I said the part where you power on the radio with 3 legs give out 11.6 v which match the battery charge, the only part that I find not doing the job is the TX module bay.
But very appreciate if you let me know what do I have to check to make sure of not making wrong steps.


User avatar
jhsa
Posts: 17814
Joined: Tue Dec 27, 2011 5:13 pm
Country: Germany

Re: 9xtrem burnt ..how? Don't know but wanna repair...please help

Post by jhsa » Wed Nov 16, 2016 10:48 am

I thought so :)
What RF module?
Did you insert/remove the RF module while the radio was ON?

This would be very helpful information that could help others as well. That is why I am asking

Thanks

João
My er9x/Ersky9x/eepskye Video Tutorials
https://www.youtube.com/playlist?list=PL5uJhoD7sAKidZmkhMpYpp_qcuIqJXhb9

Donate to Er9x/Ersky9x:
https://www.paypal.com/cgi-bin/webscr?cmd=_s-xclick&hosted_button_id=YHX43JR3J7XGW

Abach
Posts: 20
Joined: Tue Nov 15, 2016 5:43 pm
Country: -

Re: 9xtrem burnt ..how? Don't know but wanna repair...please help

Post by Abach » Wed Nov 16, 2016 11:07 am

That could be what happens. ...yes ...I think I did plug in out the module with the radio on :cry:
I can say that 100% sure that I did 'cause it was month and a half ago but yes as far as I remember will give it a 90% .
Attachments
20161116_120251.jpg
Screenshot_2016-11-16-12-00-16.jpg
Screenshot_2016-11-16-12-01-09.jpg

User avatar
jhsa
Posts: 17814
Joined: Tue Dec 27, 2011 5:13 pm
Country: Germany

Re: 9xtrem burnt ..how? Don't know but wanna repair...please help

Post by jhsa » Wed Nov 16, 2016 11:11 am

You stil didn't say what RF module was that?? ;) :)

João
My er9x/Ersky9x/eepskye Video Tutorials
https://www.youtube.com/playlist?list=PL5uJhoD7sAKidZmkhMpYpp_qcuIqJXhb9

Donate to Er9x/Ersky9x:
https://www.paypal.com/cgi-bin/webscr?cmd=_s-xclick&hosted_button_id=YHX43JR3J7XGW

Abach
Posts: 20
Joined: Tue Nov 15, 2016 5:43 pm
Country: -

Re: 9xtrem burnt ..how? Don't know but wanna repair...please help

Post by Abach » Wed Nov 16, 2016 11:14 am

This are the tx modules....both original ones
Attachments
1479294846022189578919.jpg

Abach
Posts: 20
Joined: Tue Nov 15, 2016 5:43 pm
Country: -

Re: 9xtrem burnt ..how? Don't know but wanna repair...please help

Post by Abach » Wed Nov 16, 2016 11:15 am

jhsa wrote:You stil didn't say what RF module was that?? ;) :)

João
Sorry, was looking 4 them

User avatar
jhsa
Posts: 17814
Joined: Tue Dec 27, 2011 5:13 pm
Country: Germany

Re: 9xtrem burnt ..how? Don't know but wanna repair...please help

Post by jhsa » Wed Nov 16, 2016 11:26 am

hmm, flysky modules..
Maybe something shorted when you inserted/remove the modules with the radio ON. Never do that. It has caused all kinds of trouble to other people as well.
Did those modules work afterwards in another radio?

João
My er9x/Ersky9x/eepskye Video Tutorials
https://www.youtube.com/playlist?list=PL5uJhoD7sAKidZmkhMpYpp_qcuIqJXhb9

Donate to Er9x/Ersky9x:
https://www.paypal.com/cgi-bin/webscr?cmd=_s-xclick&hosted_button_id=YHX43JR3J7XGW

Abach
Posts: 20
Joined: Tue Nov 15, 2016 5:43 pm
Country: -

Re: 9xtrem burnt ..how? Don't know but wanna repair...please help

Post by Abach » Wed Nov 16, 2016 11:35 am

One of them , left in the photo, did not work , the other one don't know because after what happened dont have other modular radio to check.
After this, will make sure that the radio is off before changing module...I did know but was one of those mistakes that u have to pay someday

Abach
Posts: 20
Joined: Tue Nov 15, 2016 5:43 pm
Country: -

Re: 9xtrem burnt ..how? Don't know but wanna repair...please help

Post by Abach » Wed Nov 16, 2016 3:17 pm

So any info ?,please, am I in the right direction?did I check everything or do I miss something??
If I replace that component it should work,doesnt it?
:?: :?: :?:

User avatar
jhsa
Posts: 17814
Joined: Tue Dec 27, 2011 5:13 pm
Country: Germany

Re: 9xtrem burnt ..how? Don't know but wanna repair...please help

Post by jhsa » Wed Nov 16, 2016 4:45 pm

Well, let's hope you didn't do any more damage by inserting / removing the module with the radio ON.

João
My er9x/Ersky9x/eepskye Video Tutorials
https://www.youtube.com/playlist?list=PL5uJhoD7sAKidZmkhMpYpp_qcuIqJXhb9

Donate to Er9x/Ersky9x:
https://www.paypal.com/cgi-bin/webscr?cmd=_s-xclick&hosted_button_id=YHX43JR3J7XGW

ReSt
Posts: 1454
Joined: Tue Dec 27, 2011 11:34 pm
Country: -

Re: 9xtrem burnt ..how? Don't know but wanna repair...please help

Post by ReSt » Wed Nov 16, 2016 5:59 pm

Here are some pictures of the basic boards with the voltages you can check
https://www.rcgroups.com/forums/showpos ... count=6754

Reinhard

Abach
Posts: 20
Joined: Tue Nov 15, 2016 5:43 pm
Country: -

Re: 9xtrem burnt ..how? Don't know but wanna repair...please help

Post by Abach » Wed Nov 16, 2016 6:02 pm

jhsa wrote:Well, let's hope you didn't do any more damage by inserting / removing the module with the radio ON.

João
Do I have to check something else?

Is this http://www.digikey.com/product-detail/e ... ND/1855948 the right component?

Abach
Posts: 20
Joined: Tue Nov 15, 2016 5:43 pm
Country: -

Re: 9xtrem burnt ..how? Don't know but wanna repair...please help

Post by Abach » Wed Nov 16, 2016 6:03 pm

ReSt wrote:Here are some pictures of the basic boards with the voltages you can check
https://www.rcgroups.com/forums/showpos ... count=6754

Reinhard
Thank you so much!!!!

Abach
Posts: 20
Joined: Tue Nov 15, 2016 5:43 pm
Country: -

Re: 9xtrem burnt ..how? Don't know but wanna repair...please help

Post by Abach » Wed Nov 16, 2016 6:05 pm

ReSt wrote:Here are some pictures of the basic boards with the voltages you can check
https://www.rcgroups.com/forums/showpos ... count=6754

Reinhard
Thanks again!!!!is there something similar but for the 9xtreme??

Abach
Posts: 20
Joined: Tue Nov 15, 2016 5:43 pm
Country: -

Re: 9xtrem burnt ..how? Don't know but wanna repair...please help

Post by Abach » Wed Nov 16, 2016 6:38 pm

Now when I was gonna check the voltage I have switch on the radio whiout all the wires from 9xtrem to 9x connected :shock: :shock:
What a messy mind this one that I have ,
So adding new problem, plug everything in place and is now turning on, it blink 3 times and show a 9xtreme and r00.3 on the screen.
Attachments
1479321431704-1975218894.jpg

User avatar
jhsa
Posts: 17814
Joined: Tue Dec 27, 2011 5:13 pm
Country: Germany

Re: 9xtrem burnt ..how? Don't know but wanna repair...please help

Post by jhsa » Wed Nov 16, 2016 9:41 pm

Is the 9xtreme screwed on top of the 9x mainboard?
Perhaps the pogo pins are not making good contact to the little pads on the 9x board
João
My er9x/Ersky9x/eepskye Video Tutorials
https://www.youtube.com/playlist?list=PL5uJhoD7sAKidZmkhMpYpp_qcuIqJXhb9

Donate to Er9x/Ersky9x:
https://www.paypal.com/cgi-bin/webscr?cmd=_s-xclick&hosted_button_id=YHX43JR3J7XGW

Abach
Posts: 20
Joined: Tue Nov 15, 2016 5:43 pm
Country: -

Re: 9xtrem burnt ..how? Don't know but wanna repair...please help

Post by Abach » Wed Nov 16, 2016 10:38 pm

jhsa wrote:Is the 9xtreme screwed on top of the 9x mainboard?
Perhaps the pogo pins are not making good contact to the little pads on the 9x board
João
Wuaaaa. ...didnt remember that at all...it is not even close to touch the 9x board!!!r u watching me from a spy cam??
Thanks that is what was happening. ..now is fine....

Abach
Posts: 20
Joined: Tue Nov 15, 2016 5:43 pm
Country: -

Re: 9xtrem burnt ..how? Don't know but wanna repair...please help

Post by Abach » Wed Nov 16, 2016 10:41 pm

ReSt wrote:Here are some pictures of the basic boards with the voltages you can check
https://www.rcgroups.com/forums/showpos ... count=6754

Reinhard
This is check and all good to go....

User avatar
jhsa
Posts: 17814
Joined: Tue Dec 27, 2011 5:13 pm
Country: Germany

Re: RE: Re: 9xtrem burnt ..how? Don't know but wanna repair...please help

Post by jhsa » Wed Nov 16, 2016 10:53 pm

Abach wrote:]
Wuaaaa. ...didnt remember that at all...it is not even close to touch the 9x board!!!r u watching me from a spy cam??
Thanks that is what was happening. ..now is fine....
No spy cams here. Just some grey material between my ears :)
Sometimes it fails as well ;)

João
My er9x/Ersky9x/eepskye Video Tutorials
https://www.youtube.com/playlist?list=PL5uJhoD7sAKidZmkhMpYpp_qcuIqJXhb9

Donate to Er9x/Ersky9x:
https://www.paypal.com/cgi-bin/webscr?cmd=_s-xclick&hosted_button_id=YHX43JR3J7XGW

Abach
Posts: 20
Joined: Tue Nov 15, 2016 5:43 pm
Country: -

Re: 9xtrem burnt ..how? Don't know but wanna repair...please help

Post by Abach » Thu Nov 17, 2016 9:10 pm

Seriously,
Please will someone be able to answer any of my questions? will be very appreciated !!!!!! :!: :!: :!:

thanks in advance

User avatar
MikeB
9x Developer
Posts: 15617
Joined: Tue Dec 27, 2011 1:24 pm
Country: -
Location: Poole, Dorset, UK

Re: 9xtrem burnt ..how? Don't know but wanna repair...please help

Post by MikeB » Thu Nov 17, 2016 10:12 pm

Abach wrote:Thanks that is what was happening. ..now is fine....
I assumed from this that all was working now, so I'm unsure what questions you now have!

Mike.
ersky9x/er9x developer
The difficult we do immediately,
The impossible takes a little longer!

s_mack
Posts: 879
Joined: Thu Dec 29, 2011 6:11 am
Country: -

Re: 9xtrem burnt ..how? Don't know but wanna repair...please help

Post by s_mack » Thu Nov 17, 2016 10:42 pm

Same... I thought it was resolved?

User avatar
jhsa
Posts: 17814
Joined: Tue Dec 27, 2011 5:13 pm
Country: Germany

Re: RE: Re: 9xtrem burnt ..how? Don't know but wanna repair...please help

Post by jhsa » Thu Nov 17, 2016 11:02 pm

Abach wrote:
jhsa wrote:Well, let's hope you didn't do any more damage by inserting / removing the module with the radio ON.

João
Do I have to check something else?

Is this http://www.digikey.com/product-detail/e ... ND/1855948 the right component?
It looks like it, yes.

João
My er9x/Ersky9x/eepskye Video Tutorials
https://www.youtube.com/playlist?list=PL5uJhoD7sAKidZmkhMpYpp_qcuIqJXhb9

Donate to Er9x/Ersky9x:
https://www.paypal.com/cgi-bin/webscr?cmd=_s-xclick&hosted_button_id=YHX43JR3J7XGW

Abach
Posts: 20
Joined: Tue Nov 15, 2016 5:43 pm
Country: -

Re: 9xtrem burnt ..how? Don't know but wanna repair...please help

Post by Abach » Fri Nov 18, 2016 8:44 am

Thanks for the answer.
The thing is that what I know is from a post here so I know nothing for sure.
The component is clear now.
-Should I check others in the 9xtreme?
-Could someone give me more link where to buy the component?have been searching on god Google but nothing near and the cost from digi key for shipping is 20€....found this:
- AO3407A X7HV AO3407 A7TA SOT-23 P-channel MOSFET 30 V 4.3A
http://s.aliexpress.com/RNjQRFJv
-https://www.amazon.com/20PCS-AO3407A-MO ... UTF8&psc=1

Worthy to buy, are them the same?

The only thing that doesn't work is the tx output as far as I have check following the post from burnt/reversed bateries, and that makes the radio unusable.Is that the mosfet that control the tx output?
Sorry if my English + grey material between my ears are a mess.

Testo
Posts: 20
Joined: Tue Oct 20, 2015 6:59 pm
Country: -

Re: 9xtrem burnt ..how? Don't know but wanna repair...please help

Post by Testo » Fri Nov 18, 2016 9:15 am

Maybe my Thread can help you a little bit:
viewtopic.php?f=126&t=7829&p=105889#p105889

User avatar
jhsa
Posts: 17814
Joined: Tue Dec 27, 2011 5:13 pm
Country: Germany

Re: 9xtrem burnt ..how? Don't know but wanna repair...please help

Post by jhsa » Fri Nov 18, 2016 9:21 am

Yes they look like they are the same part.
In my opinion, You need to get that working in order to find out if there is any other damage, unless you own an oscilloscope. :)
Do you have a trainer cable ( 3.5mm jack plug to 3.5mm jack plug)? With that (instead of the oscilloscope ;) ) you could test if the radio is outputting a PPM signal to the module. It already did happen that removing/inserting the module with the radio ON, damaged the processor pin that outputs that signal. Some people were lucky though..
But another little test, when you turn the radio off, does it wait a second or two before it turns off, displaying "shutting down", or does it turn off immediately as soon as you turn the power switch off?

João
My er9x/Ersky9x/eepskye Video Tutorials
https://www.youtube.com/playlist?list=PL5uJhoD7sAKidZmkhMpYpp_qcuIqJXhb9

Donate to Er9x/Ersky9x:
https://www.paypal.com/cgi-bin/webscr?cmd=_s-xclick&hosted_button_id=YHX43JR3J7XGW

Post Reply

Return to “9Xtreme upgrade board”