FrSky alt sensor

ersky9xr is the port of the er9x firmware to the 9XRPRO radio.
Post Reply
michel49
Posts: 109
Joined: Sun Oct 07, 2012 10:59 am
Country: -

FrSky alt sensor

Post by michel49 » Sun May 06, 2018 7:27 am

I can't find how to set the telemetry menu of the 221 FW to make the alt sensor work when linked with the A2 input of the D8 Rx; it works fine with my OpenTx Horus.

User avatar
MikeB
9x Developer
Posts: 15523
Joined: Tue Dec 27, 2011 1:24 pm
Country: -
Location: Poole, Dorset, UK

Re: FrSky alt sensor

Post by MikeB » Sun May 06, 2018 6:13 pm

I assume this is for the Vario, rather than altitude.
First, go to "Model Setup", select Telemetry, then "Vario" from the popup.
Set the Source to A2.
Select a switch to enable the vario tones.
You may then need to adjust the sensitivity value to quite a large value e.g. 50 to get a good response.

Mike
ersky9x/er9x developer
The difficult we do immediately,
The impossible takes a little longer!

michel49
Posts: 109
Joined: Sun Oct 07, 2012 10:59 am
Country: -

Re: FrSky alt sensor

Post by michel49 » Tue May 08, 2018 7:29 am

Thanks Mike, of course it is the vario sensor, but I need to display the altitude; I remember it worked some (!) years ago with an old FW...

User avatar
Kilrah
Posts: 9451
Joined: Sat Feb 18, 2012 6:56 pm
Country: Switzerland

Re: FrSky alt sensor

Post by Kilrah » Tue May 08, 2018 11:03 am

If I remember well you can't get altitude from A2, that only gives vertical speed.

Altitude needs to come from hub telemetry.

User avatar
MikeB
9x Developer
Posts: 15523
Joined: Tue Dec 27, 2011 1:24 pm
Country: -
Location: Poole, Dorset, UK

Re: FrSky alt sensor

Post by MikeB » Tue May 08, 2018 1:16 pm

I assumed from the reference to A2 you were trying to get the vertical speed reported.
For the altitude, you need to connect the Data Out port on the Vario to the serial port on the receiver ("D" type Rx).
I assume you are using a 9XR-PRO (from the thread we are in), what Tx module are you using?

Mike
ersky9x/er9x developer
The difficult we do immediately,
The impossible takes a little longer!


michel49
Posts: 109
Joined: Sun Oct 07, 2012 10:59 am
Country: -

Re: FrSky alt sensor

Post by michel49 » Fri May 11, 2018 7:49 am

Yes, I use an old glider with the vario sensor plugged on the A2 port of the "D" Rx and the multi module 9XRPRO; what is strange is the last time I fly it it worked fine but, of course, not with the multi module. I will give it a try with the XJT module.

User avatar
MikeB
9x Developer
Posts: 15523
Joined: Tue Dec 27, 2011 1:24 pm
Country: -
Location: Poole, Dorset, UK

Re: FrSky alt sensor

Post by MikeB » Fri May 11, 2018 11:08 am

You may have a problem with the polarity of the telemetry data, depending on the options chosen in the multi module.

From the main screen, go UP LONG, then RIGHT about 7 times to the "DEBUG" display. At the bottom of the screen is "TelRxCount". This is a running total of the bytes received from the telemetry. Is this changing?
If it is changing, then you are receiving something. Check the settings in the Telemetry menu for which COM port the telemetry is on (you need COM1) and the COM port Invert. Try changing the COM port Invert so you change the COM 1 polarity.

Mike
ersky9x/er9x developer
The difficult we do immediately,
The impossible takes a little longer!

michel49
Posts: 109
Joined: Sun Oct 07, 2012 10:59 am
Country: -

Re: FrSky alt sensor

Post by michel49 » Sun May 13, 2018 11:12 am

Thanks Mike, I have to add the telemetry works fine except the vario sensor; I get RSSI and voltage sensor linked to A1; I checked an other old glider with the same Rx?sensor with the same result.
Of course at the time I flew those gliders the MM. don't exist...when I tell it works with Opentx it uses the internal module so it seems the issue come from Ersky9x/mmodule.

User avatar
MikeB
9x Developer
Posts: 15523
Joined: Tue Dec 27, 2011 1:24 pm
Country: -
Location: Poole, Dorset, UK

Re: FrSky alt sensor

Post by MikeB » Sun May 13, 2018 11:50 am

Please confirm if you have the Data Out port on the Vario connected to the serial port on the receiver ("D" type Rx), not A2.

Mike
ersky9x/er9x developer
The difficult we do immediately,
The impossible takes a little longer!

michel49
Posts: 109
Joined: Sun Oct 07, 2012 10:59 am
Country: -

Re: FrSky alt sensor

Post by michel49 » Mon May 14, 2018 12:42 pm

Yes it is connected, and as I told it works with Horus/internal module/Opentx

maybe the "Alt" option in the telemetry menu of the 9XR-Pro match only the Sport connection ?

User avatar
MikeB
9x Developer
Posts: 15523
Joined: Tue Dec 27, 2011 1:24 pm
Country: -
Location: Poole, Dorset, UK

Re: FrSky alt sensor

Post by MikeB » Mon May 14, 2018 1:40 pm

I'll see if I can check it is OK with the multiprotocol module, I certainly had that setup working with a DJT in a 9X.

You might try creating a raw log file, and posting it so I can see what you are receiving. RSSI, A1 and A2 are handled differently in the module to the user data on the serial port of the Rx.
See here for how to create a raw log file on the SD card: http://openrcforums.com/forum/viewtopic ... ng#p123508.

Mike
ersky9x/er9x developer
The difficult we do immediately,
The impossible takes a little longer!

Post Reply

Return to “ersky9xr”