[SUPPORT] OpenLRSng support thread

Support and help for the OpenLRSng project.

Moderator: kha

User avatar
njozsef
Posts: 29
Joined: Tue Jan 24, 2012 2:00 pm
Country: -
Location: Hungary

Re: [SUPPORT] OpenLRSng support thread

Post by njozsef » Thu Jul 16, 2015 9:35 am

Hi developers.

I working the various camera on gimbal. Serious problem remote camera shooting or other ordenary TTL remotely device (GPI). I would without it RC switch and any unwanted parts.
Please development new selectable output type (TTL) only logical low and high. (low<1500<high)

I would be very grateful for it.
Thank you .
Jozsef

kha
Posts: 38
Joined: Fri Aug 09, 2013 6:16 pm
Country: -
Location: Espoo
Contact:

Re: [SUPPORT] OpenLRSng support thread

Post by kha » Thu Jul 16, 2015 10:38 am

Been there for ever, just select Sxx (S for switch) in the rx pin configuration.

--kha via mobile

gbine
Posts: 1
Joined: Wed Aug 05, 2015 5:32 am
Country: Canada
Location: Quesnel/Vanderhoof

Re: [SUPPORT] OpenLRSng support thread

Post by gbine » Wed Aug 05, 2015 5:41 am

leocopter wrote:Hi,
I'm having problems with telemetry on OpenLRSng.
I have it successfully set on my Taranis with both D4R and X6R (using s-port), using FRSKY protocol (with Harakiri on a Flip32 with signal inverter or a Naze32 without) or Mavlink with a Mavlink to FRSKY converter board (a flashed Pro Mini). The converter works also with an APM.
I did the mod shown in the Wiki for a 1W OrangeTx UHF. After that it would not connect to the serial port in the OpenLRSng Google chrome app ... I desoldered the transistor + 3 X 1K resistors and could connect again ... (even with out the R2 resistor ...).
Then I figured that I could invert the signal between the Flight controller and the receiver (the same way I do with the FRSKY receivers) using the FRSKY protocol ... no go. I tried many settings on the Tx Module : FRSKY, FRSKY smartport, 8 ch , 12 ch ... I tried the Mavlink protocol with the converter board (no signal inversion) ... I fed 3,3v devices to the Tx and RX pins on the OrangeTX ... nothing.
Does anyone have a working setup ... and perhaps can tell me what I'm doing wrong ? :shock:

Chris
Chris, did you ever solve this issue? I just did the mod and ran into the same thing. :(
BTW - You only have to disconnect the TX connection to get it to work again.

Gordon

humblehacker
Posts: 27
Joined: Tue Jun 30, 2015 4:19 pm
Country: -

Re: [SUPPORT] OpenLRSng support thread

Post by humblehacker » Mon Oct 05, 2015 6:10 pm

Hello,
I have an OrangeRX OpenLRS module which I've been using with my Turnigy 9xr Pro. Yesterday I tried to connect to the configurator by following the instructions stating that I would have to connect a 3.3v FTDI converter while the module was inserted in the transmitter housing. I had successfully flashed to the latest firmware via the configurator using what I thought was this method but now I can't remember if I used an FTDI or a JTAG... Anyway, something happened in the process that appears to have shorted my TX!? The 9XR-Pro won't boot at all now and only emits a faint buzzing sound instead! I can confirm that the FTDI was running at 3.3v and I have used it for other 3.3v sensitive projects in the past. But obviously SOMETHING went wrong... Hobbyking support has thus far been useless... Can anybody help figure out went went wrong?

alexraz
Posts: 2
Joined: Wed Nov 25, 2015 1:29 am
Country: -

Re: [SUPPORT] OpenLRSng support thread

Post by alexraz » Wed Nov 25, 2015 2:32 am

Hi,

My TX and RX (both OrangeRX on the 3.8.5 fw) won't bind. This has happened to me before and re-flashing the RX usually did the trick. When I tried to re-flash this time, however, it failed and only gives me this:

10:23:22 -- Serial port successfully opened with ID: 35
10:23:23 -- Chip recognized as ATmega328P
10:23:23 -- Erasing EEPROM
10:23:31 -- Writing to flash
10:23:33 -- STK500 - Timed out, programming failed
10:23:33 -- Serial port successfully closed

I'm on my second OrangeRX LRS RX. The same thing happened to the first one. Is there anything I can do to recover these RXs?

Thanks! I hope somebody is still monitoring ;)


Crashsalot
Posts: 1
Joined: Sat Nov 28, 2015 3:53 am
Country: -

Re: [SUPPORT] OpenLRSng support thread

Post by Crashsalot » Sat Nov 28, 2015 3:59 am

We're trying to fly with more than one OpenLRS in the air at the same time. Me and my buddy were a little hesitant because as soon as we turned the second transmitter on, both RSSIs went down from 100% to 40ish... both planes still on the ground. Any suggestions? We already separated the frequencies a bit but still have that drop in rssi when the second transmitter comes on.

alexraz
Posts: 2
Joined: Wed Nov 25, 2015 1:29 am
Country: -

Re: [SUPPORT] OpenLRSng support thread

Post by alexraz » Fri Dec 04, 2015 1:18 am

alexraz wrote:Hi,

My TX and RX (both OrangeRX on the 3.8.5 fw) won't bind. This has happened to me before and re-flashing the RX usually did the trick. When I tried to re-flash this time, however, it failed and only gives me this:

10:23:22 -- Serial port successfully opened with ID: 35
10:23:23 -- Chip recognized as ATmega328P
10:23:23 -- Erasing EEPROM
10:23:31 -- Writing to flash
10:23:33 -- STK500 - Timed out, programming failed
10:23:33 -- Serial port successfully closed

I'm on my second OrangeRX LRS RX. The same thing happened to the first one. Is there anything I can do to recover these RXs?

Thanks! I hope somebody is still monitoring ;)
In case somebody else experiences this, I've found the solution. Using USBASP, I flashed both with a bootloader. I used Optiboot bootloader. After that, both worked with the configurator worked again. Note that the OrangeRX Rx boards can only take 3.3v on the programing pins so you need to power it via the channel pins with a 5v bec and NOT connect the vcc pin from the programmer.

DakotaKid
Posts: 3
Joined: Thu Mar 17, 2016 3:27 am
Country: -

Re: [SUPPORT] OpenLRSng support thread

Post by DakotaKid » Mon Mar 28, 2016 5:38 pm

I am trying to program my Orange LRS UHF transmitter / RX setup.

Using the arduino 1.6.8 software I have compiled for the Tx.
I have a FTDI plugged into my PC usb port.

I have selected the com port and the pro mini board.

My question is what do i set the programmer to for the FTDI serial programmer?

Image

User avatar
Kilrah
Posts: 8970
Joined: Sat Feb 18, 2012 6:56 pm
Country: United Arab Emirates

Re: [SUPPORT] OpenLRSng support thread

Post by Kilrah » Mon Mar 28, 2016 6:49 pm

You don't, that's only needed to flash the bootloader to a blank chip.

DakotaKid
Posts: 3
Joined: Thu Mar 17, 2016 3:27 am
Country: -

Re: [SUPPORT] OpenLRSng support thread

Post by DakotaKid » Mon Mar 28, 2016 11:00 pm

Kilrah

I get this error when I try and upload with programmer.
I feel that I need to set it to something.


Sketch uses 26,574 bytes (86%) of program storage space. Maximum is 30,720 bytes.
Global variables use 1,427 bytes (69%) of dynamic memory, leaving 621 bytes for local variables. Maximum is 2,048 bytes.
I:\Program Files (x86)\Arduino\hardware\tools\avr/bin/avrdude -CI:\Program Files (x86)\Arduino\hardware\tools\avr/etc/avrdude.conf -v -patmega328p -cusbasp -Pusb -Uflash:w:I:\Users\rvaagen\AppData\Local\Temp\build45c30822eee3fe058ba77123b663d7a1.tmp/openLRSng_TX.ino.hex:i

avrdude: Version 6.0.1, compiled on Apr 15 2015 at 19:59:58
Copyright (c) 2000-2005 Brian Dean, http://www.bdmicro.com/
Copyright (c) 2007-2009 Joerg Wunsch

System wide configuration file is "I:\Program Files (x86)\Arduino\hardware\tools\avr/etc/avrdude.conf"

Using Port : usb
Using Programmer : usbasp
avrdude: error: could not find USB device with vid=0x16c0 pid=0x5dc vendor='www.fischl.de' product='USBasp'

avrdude done. Thank you.

DakotaKid
Posts: 3
Joined: Thu Mar 17, 2016 3:27 am
Country: -

Re: [SUPPORT] OpenLRSng support thread

Post by DakotaKid » Tue Mar 29, 2016 12:57 am

Well, I figured it out.

I used the Arduino program to load a boot loader with the usbasp.

I was able to use the Chrome openLRSng Configurator and program both of my modules
with the FTDI.

It seems to bind ok so now to put it in the air.

Thanks

ljftnt
Posts: 1
Joined: Sun Apr 03, 2016 11:28 am
Country: -

Re: [SUPPORT] OpenLRSng support thread

Post by ljftnt » Sun Apr 03, 2016 11:38 am

I want to made a openlrs Hardware with si4463.
because si4463 have Higher sensitivity and More stable。
Can not develop the firmware with si4463?

pyr8
Posts: 53
Joined: Sun Apr 13, 2014 4:43 pm
Country: -

Re: [SUPPORT] OpenLRSng support thread

Post by pyr8 » Mon Apr 18, 2016 3:11 pm

I am having an issue with "Channel 1" not working on a "OrangeRx Open LRS 433MHz".

No matter what pin I assign channel 1 too, I cannot get it to work.
Anyone have any ideas?

RobinBones
Posts: 2
Joined: Wed Jun 22, 2016 3:27 pm
Country: -

Re: [SUPPORT] OpenLRSng support thread

Post by RobinBones » Wed Jun 22, 2016 3:37 pm

I am trying to flash my Orange Rx module. I've done it once before years ago.
I am using the same programmer I used in the past. I tried several USB ports on two different computers, and two different USB cables.
Each time I get the following results.
09:27:41 -- Serial port successfully opened with ID: 6
09:27:41 -- Chip recognized as ATmega328P
09:27:41 -- Erasing EEPROM
09:27:49 -- Writing to flash
09:27:56 -- Verifying flash
09:28:04 -- Verifying failed
09:28:04 -- Programming: FAILED
09:28:04 -- Serial port successfully closed
I tried downloading an older version of the firmware, and I got the same results. What else can I try to get this working again?

dispetto77
Posts: 2
Joined: Wed Dec 07, 2016 11:19 pm
Country: -

Re: [SUPPORT] OpenLRSng support thread

Post by dispetto77 » Fri Dec 09, 2016 8:49 pm

Hi

Did you see this?
Here is a new Openlrsng module from Hobbyking. Plug&play for APM users. No more need of 3dr radios.
Rx is 1W for telemetry link

https://hobbyking.com/en_us/orangerx-op ... tooth.html

Image

Inviato dal mio RAINBOW 4G utilizzando Tapatalk

sandmen
Posts: 7
Joined: Mon Apr 09, 2012 9:07 am
Country: -

Re: [SUPPORT] OpenLRSng support thread

Post by sandmen » Fri Mar 24, 2017 7:55 pm

@dispetto77 or anyone,
did you know which kind of FW the receiver is using ?

jtbrownlee
Posts: 1
Joined: Sun May 14, 2017 7:04 pm
Country: -

Re: [SUPPORT] OpenLRSng support thread

Post by jtbrownlee » Sun May 14, 2017 7:48 pm

Does anyone know anything about the receiver in this set? I have found very little documentation for it and can't firgure out where to connect to it or what firmware to use.

podhrmic
Posts: 1
Joined: Tue May 16, 2017 11:38 pm
Country: -

Re: [SUPPORT] OpenLRSng support thread

Post by podhrmic » Tue May 16, 2017 11:48 pm

Hi,

I recently got a HAWKEYE DELUXETX TARANIS JR TURNIGY COMPATIBLE transmitter (from here http://www.hobbiesfly.com/transmitter-r ... tible.html ) and a BROTRONICS 4CH REMIX receiver (from here http://www.hobbiesfly.com/transmitter-r ... eiver.html ).

Right after unpacking I tried to connect both modules to the configurator, but although the configurator was able to open the serial port, it never received any answer from the modules. I tried all baud rates just to be sure, but still nothing.

Then I reprogrammed both modules - I tried the latest stable and latest master versions - and still no response on the configurator.

Have you had a problem like this before? It doesn't seem to be a hardware issue - if I program the modules with custom program, it runs as expected.

I am hoping this forum is still somehow active, even thought there wasn't much activity recently.

Post Reply

Return to “OpenLRSng”

Who is online

Users browsing this forum: No registered users and 1 guest