turnigy 9x won't turn on after soldering

User avatar
jhsa
Posts: 17662
Joined: Tue Dec 27, 2011 5:13 pm
Country: Germany

Re: turnigy 9x won't turn on after soldering

Post by jhsa » Sun Jul 10, 2016 8:28 am

We will do our best to revive that radio.
Did you check the LCD ribbon is correctly inserted as I asked you above?

Ok, please have a look at the picture below.
WITH THE POWER OFF, measure the resistance between point 1 (Red) and all the pins marked RED on the chip. Then measure the resistance between point 2 (Black) and all the pins marked black on the chip. Multimeter set to the 200 ohm scale.
You expect to measure a short (close to zero ohms) in all measurements.

Now set your multimeter to read voltage. 20V scale is fine.
TURN THE RADIO ON. measure the voltage between point number 1 and ground. You should see 5V.

BE CAREFUL NOT TO SHORT ANYTHING WITH THE PROBES WHILE MEASURING VOLTAGE.

João
Attachments
9X Board_Chip_Vcc and Gnd.jpg
My er9x/Ersky9x/eepskye Video Tutorials
https://www.youtube.com/playlist?list=PL5uJhoD7sAKidZmkhMpYpp_qcuIqJXhb9

Donate to Er9x/Ersky9x:
https://www.paypal.com/cgi-bin/webscr?cmd=_s-xclick&hosted_button_id=YHX43JR3J7XGW

kasturiGM
Posts: 46
Joined: Sat Jul 09, 2016 3:18 am
Country: -

Re: turnigy 9x won't turn on after soldering

Post by kasturiGM » Sun Jul 10, 2016 11:45 am

sorry i didn't see the reply on this page. on all points i got somewhere between 0.9-1.2v. i think my multimeter isn't properly calibrated.
and i got about 4.92v between point number 1 and point number 2 ground. just the ground on point number 2 right and not on the processor.
yes, i have checked the lcd ribbon and even swap with my old lcd before. nothing change.

User avatar
jhsa
Posts: 17662
Joined: Tue Dec 27, 2011 5:13 pm
Country: Germany

Re: turnigy 9x won't turn on after soldering

Post by jhsa » Sun Jul 10, 2016 12:02 pm

kasturiGM wrote:sorry i didn't see the reply on this page. on all points i got somewhere between 0.9-1.2v. i think my multimeter isn't properly calibrated.
You mean 0.9 - 1.2 Ohms not volts, right? You measured resistance not voltage?
and i got about 4.92v between point number 1 and point number 2 ground. just the ground on point number 2 right and not on the processor.
If the answer to my question above is yes, then the processor seems to be powered.
Preparing next check, meanwhile please answer my question ;)

João
My er9x/Ersky9x/eepskye Video Tutorials
https://www.youtube.com/playlist?list=PL5uJhoD7sAKidZmkhMpYpp_qcuIqJXhb9

Donate to Er9x/Ersky9x:
https://www.paypal.com/cgi-bin/webscr?cmd=_s-xclick&hosted_button_id=YHX43JR3J7XGW

User avatar
jhsa
Posts: 17662
Joined: Tue Dec 27, 2011 5:13 pm
Country: Germany

Re: turnigy 9x won't turn on after soldering

Post by jhsa » Sun Jul 10, 2016 12:05 pm

Please confirm there is no short across this capacitor. Set multimeter to read resistance (ohms).
You should see a high resistance or no connection at all.

João
Attachments
9X_Board_Remove RESET Cap.jpg
My er9x/Ersky9x/eepskye Video Tutorials
https://www.youtube.com/playlist?list=PL5uJhoD7sAKidZmkhMpYpp_qcuIqJXhb9

Donate to Er9x/Ersky9x:
https://www.paypal.com/cgi-bin/webscr?cmd=_s-xclick&hosted_button_id=YHX43JR3J7XGW

User avatar
jhsa
Posts: 17662
Joined: Tue Dec 27, 2011 5:13 pm
Country: Germany

Re: turnigy 9x won't turn on after soldering

Post by jhsa » Sun Jul 10, 2016 12:12 pm

Please set the multimeter to read resistance using the 20K scale.

Then measure all the resistors inside the red rectangle on the photo.
The top resistors should measure around 10K (10 kilo ohms = 10000 ohms)
The bottom resistors should measure around 5.1K (5.1 Kilo ohms = 5100 ohms)

Please do this with POWER OFF.

João
Attachments
9x_Multimeter_Res_20K.jpg
9X Board_Measure Display Resistors.jpg
My er9x/Ersky9x/eepskye Video Tutorials
https://www.youtube.com/playlist?list=PL5uJhoD7sAKidZmkhMpYpp_qcuIqJXhb9

Donate to Er9x/Ersky9x:
https://www.paypal.com/cgi-bin/webscr?cmd=_s-xclick&hosted_button_id=YHX43JR3J7XGW


kasturiGM
Posts: 46
Joined: Sat Jul 09, 2016 3:18 am
Country: -

Re: turnigy 9x won't turn on after soldering

Post by kasturiGM » Sun Jul 10, 2016 12:46 pm

yes, they are in ohms. there is no reading for the capacitor. so i guess there is no short then, it has to be done without the power on right?

as for the resistors for the top part, for the very first 3 resistor the reading is around 6.8-7.0 ohms and i am using the 20k scale but then the readings keep going higher to around 9.0 ohms.

for the bottom part i got all the reading close to 5.0 ohms in 20k scale as well.

kasturiGM
Posts: 46
Joined: Sat Jul 09, 2016 3:18 am
Country: -

Re: turnigy 9x won't turn on after soldering

Post by kasturiGM » Sun Jul 10, 2016 1:03 pm

ops..sorry. for the top part, i got about 17 ohms in 20k scale. but it seems not consistent. i don't know whether the problem is with the probe on my multimeter itself or the resistor. i mean, it will get about 17 ohms for a second or two then fluctuate to around 6 ohms.

kasturiGM
Posts: 46
Joined: Sat Jul 09, 2016 3:18 am
Country: -

Re: turnigy 9x won't turn on after soldering

Post by kasturiGM » Sun Jul 10, 2016 1:05 pm

but i got more consistent reading for the bottom part.

User avatar
jhsa
Posts: 17662
Joined: Tue Dec 27, 2011 5:13 pm
Country: Germany

Re: turnigy 9x won't turn on after soldering

Post by jhsa » Sun Jul 10, 2016 1:10 pm

Strange.. Are you sure you don't mean Kilo ohms? :o
I do not believe you are reading ohms there. it must be kilo ohms.

Please post a picture of your multimeter while measuring one of the top resistors, and one of the bottom..

Power turned OFF please..

João
My er9x/Ersky9x/eepskye Video Tutorials
https://www.youtube.com/playlist?list=PL5uJhoD7sAKidZmkhMpYpp_qcuIqJXhb9

Donate to Er9x/Ersky9x:
https://www.paypal.com/cgi-bin/webscr?cmd=_s-xclick&hosted_button_id=YHX43JR3J7XGW

kasturiGM
Posts: 46
Joined: Sat Jul 09, 2016 3:18 am
Country: -

Re: turnigy 9x won't turn on after soldering

Post by kasturiGM » Sun Jul 10, 2016 1:28 pm

i am not sure. it shows around 6.0-7.0++ on a 20k scale.
so is it 6.0 x 10k? take a look at the picture. is it correct?
Attachments
IMG_20160710_212135.jpg
this is how i take the reading

kasturiGM
Posts: 46
Joined: Sat Jul 09, 2016 3:18 am
Country: -

Re: turnigy 9x won't turn on after soldering

Post by kasturiGM » Sun Jul 10, 2016 1:43 pm

if i move to the 2000 scale which i assume is 1k scale, the reading becomes 1100++ ohms. how weird..

User avatar
jhsa
Posts: 17662
Joined: Tue Dec 27, 2011 5:13 pm
Country: Germany

Re: turnigy 9x won't turn on after soldering

Post by jhsa » Sun Jul 10, 2016 1:48 pm

if it shows 6.0, it is 6.0 kilo ohm.

Ok, I have just measured a spare board I have here.

Without the LCD connected the top resistors measure around 9.3 kilo ohms
The bottom measure around 5.1 Kilo ohms.
Could you also disconnect the LCD for now and measure them again please?

POWER OFF PLEASE.

I know this is a pain :(
But I don't have the board with me and I can only rely on the information you give me..

And according with the information that you already gave me, it seems that the processor should be working.
We are now checking the LCD circuitry.. After this measurement, we will check if the 3.3V are getting to the LCD. but please just check the resistors for now..

João
My er9x/Ersky9x/eepskye Video Tutorials
https://www.youtube.com/playlist?list=PL5uJhoD7sAKidZmkhMpYpp_qcuIqJXhb9

Donate to Er9x/Ersky9x:
https://www.paypal.com/cgi-bin/webscr?cmd=_s-xclick&hosted_button_id=YHX43JR3J7XGW

User avatar
jhsa
Posts: 17662
Joined: Tue Dec 27, 2011 5:13 pm
Country: Germany

Re: turnigy 9x won't turn on after soldering

Post by jhsa » Sun Jul 10, 2016 1:50 pm

kasturiGM wrote:if i move to the 2000 scale which i assume is 1k scale, the reading becomes 1100++ ohms. how weird..
No, 2000 is 2K scale ;) :)

João
My er9x/Ersky9x/eepskye Video Tutorials
https://www.youtube.com/playlist?list=PL5uJhoD7sAKidZmkhMpYpp_qcuIqJXhb9

Donate to Er9x/Ersky9x:
https://www.paypal.com/cgi-bin/webscr?cmd=_s-xclick&hosted_button_id=YHX43JR3J7XGW

kasturiGM
Posts: 46
Joined: Sat Jul 09, 2016 3:18 am
Country: -

Re: turnigy 9x won't turn on after soldering

Post by kasturiGM » Sun Jul 10, 2016 2:01 pm

its ok then. its a pleasure working with you, at least i learn something. it's more painful for you i think, working with a non technical guy like me ;). anyway i didn't see any changes with or without the lcd ribbon connected. the first one still measured the lowest among all the resistors and like i said before, the reading getting higher towards the end up to 9k++ ohms

User avatar
jhsa
Posts: 17662
Joined: Tue Dec 27, 2011 5:13 pm
Country: Germany

Re: turnigy 9x won't turn on after soldering

Post by jhsa » Sun Jul 10, 2016 2:21 pm

so the top ones are around 9K and the bottom ones around 5K?? you mention the first one. Is that left or right?
I'm getting confused here ;)

I enjoy helping people fixing their equipment. it is also a good training for me as i always learn something new. :)

Next, POWER OFF and please measure the resistors inside the yellow square. They should measure zero ohms (200 scale on the multimeter).

Then measure the voltage between top of the left resistor inside the yellow square, and ground. POWER ON of course. (scale of 20V on the mult.). It should read 3.3V. BE CAREFUL NOT TO SHORT ANYTHING WITH THE PROBES.

João
Attachments
9X Board_Measure Display Resistors.jpg
My er9x/Ersky9x/eepskye Video Tutorials
https://www.youtube.com/playlist?list=PL5uJhoD7sAKidZmkhMpYpp_qcuIqJXhb9

Donate to Er9x/Ersky9x:
https://www.paypal.com/cgi-bin/webscr?cmd=_s-xclick&hosted_button_id=YHX43JR3J7XGW

kasturiGM
Posts: 46
Joined: Sat Jul 09, 2016 3:18 am
Country: -

Re: turnigy 9x won't turn on after soldering

Post by kasturiGM » Sun Jul 10, 2016 2:48 pm

oh i mean top left. it has reading about 6.0k++ towards the end to the right its getting higher with the average of 9k.
i measured the resistors in yellow square and the both got about 0.8ohms.
about the voltage between resistors. how should i measure them. which ground should i put. i mean voltage measurement has polarity right. i am afraid of shorting the board.

kasturiGM
Posts: 46
Joined: Sat Jul 09, 2016 3:18 am
Country: -

Re: turnigy 9x won't turn on after soldering

Post by kasturiGM » Sun Jul 10, 2016 2:58 pm

and yes the bottom part of the resistor has a consistent value close to 5k ohms.

User avatar
jhsa
Posts: 17662
Joined: Tue Dec 27, 2011 5:13 pm
Country: Germany

Re: turnigy 9x won't turn on after soldering

Post by jhsa » Sun Jul 10, 2016 3:22 pm

kasturiGM wrote:oh i mean top left. it has reading about 6.0k++ towards the end to the right its getting higher with the average of 9k.
So, you mean they start reading 6K, but if you leave the probe in place the resistance go up to 9k?
Or do you mean the left resistor(s) measure always 6k no matter how long the probe is there?
i measured the resistors in yellow square and the both got about 0.8ohms.
That is ok thanks. If before you measured 3.3V at the voltage regulator and now those 2 resistors measure zero ohms, then the 3.3V should be present at the display ;)

João
My er9x/Ersky9x/eepskye Video Tutorials
https://www.youtube.com/playlist?list=PL5uJhoD7sAKidZmkhMpYpp_qcuIqJXhb9

Donate to Er9x/Ersky9x:
https://www.paypal.com/cgi-bin/webscr?cmd=_s-xclick&hosted_button_id=YHX43JR3J7XGW

kasturiGM
Posts: 46
Joined: Sat Jul 09, 2016 3:18 am
Country: -

Re: turnigy 9x won't turn on after soldering

Post by kasturiGM » Sun Jul 10, 2016 3:29 pm

jhsa wrote:
kasturiGM wrote:oh i mean top left. it has reading about 6.0k++ towards the end to the right its getting higher with the average of 9k.
So, you mean they start reading 6K, but if you leave the probe in place the resistance go up to 9k?
Or do you mean the left resistor(s) measure always 6k no matter how long the probe is there?

i measured the resistors in yellow square and the both got about 0.8ohms.
That is ok thanks. If before you measured 3.3V at the voltage regulator and now those 2 resistors measure zero ohms, then the 3.3V should be present at the display ;)
i am not quite understand here. so now what should i do? shouldn't i be measuring the voltage on the resistors?

João
no, i mean the first left resistor measure around 6k no matter how long. and as i move to measure the other resistors towards the right the reading got higher.

User avatar
jhsa
Posts: 17662
Joined: Tue Dec 27, 2011 5:13 pm
Country: Germany

Re: turnigy 9x won't turn on after soldering

Post by jhsa » Sun Jul 10, 2016 3:39 pm

Weird, I will let Mike comment on this if he is following this thread.
I'm afraid i'm running out of ideas. That radio should be working as far as I understand.
Now just a shot in the dark. If you insert a jack plug in the trainer port located on the back of the radio, does it turn ON?
Make sure all the switches are in the off position, that means, UP, and to the BACK. make sure the throttle stick is at minimum.

Also, do you have an RF module connected to the radio? if you turn the radio ON using the power switch, can you control a servo, or model, even if the display is dead?

João

For the next step, in case the radio doesn't do anything of the above, will be to connect the programmer to it again. We need to know if the processor is dead. I need a picture of your programmer, both sides if possible. A link to the place where you bought it would also help.
My er9x/Ersky9x/eepskye Video Tutorials
https://www.youtube.com/playlist?list=PL5uJhoD7sAKidZmkhMpYpp_qcuIqJXhb9

Donate to Er9x/Ersky9x:
https://www.paypal.com/cgi-bin/webscr?cmd=_s-xclick&hosted_button_id=YHX43JR3J7XGW

kasturiGM
Posts: 46
Joined: Sat Jul 09, 2016 3:18 am
Country: -

Re: turnigy 9x won't turn on after soldering

Post by kasturiGM » Sun Jul 10, 2016 3:59 pm

i switch the radio on, it can't control anything but still be able to bind. but i guess thats only because the module is working. when connected to the trainer, nothing happens. and yes i have the rf module on it.
oh so i got to solder the wires again..my least favourite part. it seems like every time i solder something, it gets worse. i think if i have to solder or desolder any components, it will be pretty much good as broken. i was hoping all i have to do is a simple reset. but i guess not :)

kasturiGM
Posts: 46
Joined: Sat Jul 09, 2016 3:18 am
Country: -

Re: turnigy 9x won't turn on after soldering

Post by kasturiGM » Sun Jul 10, 2016 4:07 pm

i am using this type of programmer. i thought its pretty standard.
Attachments
IMG_20160710_235336.jpg
IMG_20160710_235319.jpg

kasturiGM
Posts: 46
Joined: Sat Jul 09, 2016 3:18 am
Country: -

Re: turnigy 9x won't turn on after soldering

Post by kasturiGM » Sun Jul 10, 2016 4:09 pm

anyway, if i don't reply after this, i might be sleeping. its 12 a.m here. ill catch u guys tomorrow. thanks again.

User avatar
jhsa
Posts: 17662
Joined: Tue Dec 27, 2011 5:13 pm
Country: Germany

Re: turnigy 9x won't turn on after soldering

Post by jhsa » Sun Jul 10, 2016 4:39 pm

Ok. That is an UsbAsp, right? Do you knoe if it is working? Did you install the drivers? What OS are are you running on your computer? Windows?
Is that your programmer on the photos?

João
My er9x/Ersky9x/eepskye Video Tutorials
https://www.youtube.com/playlist?list=PL5uJhoD7sAKidZmkhMpYpp_qcuIqJXhb9

Donate to Er9x/Ersky9x:
https://www.paypal.com/cgi-bin/webscr?cmd=_s-xclick&hosted_button_id=YHX43JR3J7XGW

User avatar
MikeB
9x Developer
Posts: 15527
Joined: Tue Dec 27, 2011 1:24 pm
Country: -
Location: Poole, Dorset, UK

Re: turnigy 9x won't turn on after soldering

Post by MikeB » Sun Jul 10, 2016 7:30 pm

If the processor is powered, there are two main reasons why it might not be operating, one is the reset signal is active all the time and the other is the crystal isn't working.

With the power ON, measure the voltage across the capacitor shown in this post: viewtopic.php?f=109&t=8996&start=30#p116598. It should be 5V showing the reset is inactive.

Mike.
ersky9x/er9x developer
The difficult we do immediately,
The impossible takes a little longer!

User avatar
jhsa
Posts: 17662
Joined: Tue Dec 27, 2011 5:13 pm
Country: Germany

Re: turnigy 9x won't turn on after soldering

Post by jhsa » Sun Jul 10, 2016 8:02 pm

I asked him to measure the resistance across the reset cap and apparently it was high. But you're right, it is better to measure the voltage across it..

Yes, the crystal could also prevent the radio from working. That is one of the reasons I asked to connect the programmer. if the chip doesn't respond, he might have to replace the crystal. Or is there a better way to check the crystal?

Thanks

João
My er9x/Ersky9x/eepskye Video Tutorials
https://www.youtube.com/playlist?list=PL5uJhoD7sAKidZmkhMpYpp_qcuIqJXhb9

Donate to Er9x/Ersky9x:
https://www.paypal.com/cgi-bin/webscr?cmd=_s-xclick&hosted_button_id=YHX43JR3J7XGW

kasturiGM
Posts: 46
Joined: Sat Jul 09, 2016 3:18 am
Country: -

Re: turnigy 9x won't turn on after soldering

Post by kasturiGM » Sun Jul 10, 2016 10:44 pm

jhsa wrote:Ok. That is an UsbAsp, right? Do you knoe if it is working? Did you install the drivers? What OS are are you running on your computer? Windows?
Is that your programmer on the photos?

yes, it is an usbasp. i am not sure whether it is working or not since i never got to test it, all i can say that there is a an led glowing. I have not install anything yet and was just about to figure out how to program this radio in here when my radio is dead. i am using windows 7. yes that is my programmer in the photos.

João

kasturiGM
Posts: 46
Joined: Sat Jul 09, 2016 3:18 am
Country: -

Re: turnigy 9x won't turn on after soldering

Post by kasturiGM » Sun Jul 10, 2016 11:01 pm

hurm, i was jus about to do what you guys told me and this thing happened. my caps and probably the voltage regulator probably dead already. not sure how on earth a mistake from soldering few wires to program got to the upper side. just turn on the radio, a couple of second later, it burst into flame. i am pretty much screwed and give up right now. this is beyond my ability. tried to replace my previous board that fried because of the reversed polarity before, with my limited skills and tools combined, it just got worse. now this.
Attachments
IMG_20160711_064915.jpg

User avatar
jhsa
Posts: 17662
Joined: Tue Dec 27, 2011 5:13 pm
Country: Germany

Re: turnigy 9x won't turn on after soldering

Post by jhsa » Sun Jul 10, 2016 11:12 pm

Oh dear :( But did you solder the wires? How? What guide did you follow to do it? Obviously you were doing something very wrong. I sent you a PM.

João
My er9x/Ersky9x/eepskye Video Tutorials
https://www.youtube.com/playlist?list=PL5uJhoD7sAKidZmkhMpYpp_qcuIqJXhb9

Donate to Er9x/Ersky9x:
https://www.paypal.com/cgi-bin/webscr?cmd=_s-xclick&hosted_button_id=YHX43JR3J7XGW

kasturiGM
Posts: 46
Joined: Sat Jul 09, 2016 3:18 am
Country: -

Re: turnigy 9x won't turn on after soldering

Post by kasturiGM » Mon Jul 11, 2016 2:07 am

not yet. i was just about to do what mike told me which is checking the voltage on the capacitor. when i turn on the radio, this happened. i was excited to finally know that maybe just the reset or crystal has to be replaced. i have a few references on the google and youtube videos. everyone showing the same method which is solder 6 wires on the 6 pads.
Last edited by kasturiGM on Mon Jul 11, 2016 2:53 am, edited 1 time in total.

Post Reply

Return to “PROGRAMMERS”