Search found 51 matches

by tomismrkolj1
Sat Apr 08, 2017 7:34 pm
Forum: ersky9xr
Topic: How to enable voice function after firmware R220 upgraded
Replies: 29
Views: 1273

Re: How to enable voice function after firmware R220 upgraded

Hi, the saga of voice file crashing 9xr pro continued today. After 2 weeks or so I turned 9xr pro again. It started welcome message, but stopped in the middle. And crash of 9xr pro again. Reinstalled voice files to sd card and worked again. I start thinking that stock sd card is failing. Bought new ...
by tomismrkolj1
Wed Mar 15, 2017 9:38 pm
Forum: ersky9xr
Topic: How to enable voice function after firmware R220 upgraded
Replies: 29
Views: 1273

Re: How to enable voice function after firmware R220 upgraded

HI,

yes I calibrated voltage and it was working flawlessly.

tomi
by tomismrkolj1
Wed Mar 15, 2017 8:02 am
Forum: ersky9xr
Topic: How to enable voice function after firmware R220 upgraded
Replies: 29
Views: 1273

Re: How to enable voice function after firmware R220 upgraded

Me again, I have removed old numbered voice files from voice folder on sd card. Now everything works OK. Even RX_LOST. Funny: everything worked OK with r218 in the autmn. MikeB: regarding puffed battery with one dead cell inside 9xr pro: RX voltage was shown 11.6v eventhough it was infact only 7.4V....
by tomismrkolj1
Wed Mar 15, 2017 7:40 am
Forum: ersky9xr
Topic: How to enable voice function after firmware R220 upgraded
Replies: 29
Views: 1273

Re: How to enable voice function after firmware R220 upgraded

Hi, got the new battery, but there is still problem with one of the files: no matter which firmware I put on 9xr pro it crashes whenever file RX_LOST.wav is played. And just this file. There are some other voice files, which do not play at all, but they don't crash the 9xr pro. RX_VOLT for example w...
by tomismrkolj1
Mon Mar 06, 2017 3:45 pm
Forum: ersky9xr
Topic: How to enable voice function after firmware R220 upgraded
Replies: 29
Views: 1273

Re: How to enable voice function after firmware R220 upgraded

Mystery solved. Radio battery is puffed. One cell dead. That is why there were hangs of the radio and problems with voice. Tried with another battery and works ok. Voice works as before. Strange enough radio was showing 11.6V. 2 cells were at 3.8V and one at 0V. Luckily i did not fly the plane. It w...
by tomismrkolj1
Mon Mar 06, 2017 5:28 am
Forum: ersky9xr
Topic: How to enable voice function after firmware R220 upgraded
Replies: 29
Views: 1273

Re: How to enable voice function after firmware R220 upgraded

Yep, that is what i am saying.
Beeps do not work, when set for voice alert.
And welcome message plays fine.

I am not sure if this is fw issue, but all was working ok in november 2016 during last flight session.

MikeB, where can I find r218 or 219 fw?

tomi
by tomismrkolj1
Sun Mar 05, 2017 7:56 pm
Forum: ersky9xr
Topic: How to enable voice function after firmware R220 upgraded
Replies: 29
Views: 1273

Re: How to enable voice function after firmware R220 upgraded

Hi, actually I have updated the voice files few months ago. They are from 2015 as is seen by file time stamps. inside voice directory on sd card I have original voice files (numbers) and three directories user, system and models. Is this correct? What i am concerned about is that even selecting file...
by tomismrkolj1
Sun Mar 05, 2017 7:07 pm
Forum: ersky9xr
Topic: How to enable voice function after firmware R220 upgraded
Replies: 29
Views: 1273

Re: How to enable voice function after firmware R220 upgraded

Hi, I have problems with voice function too. Since there was winter outside, I did not test the 9xr pro after each firmware upgrade, but today I found out that voice does not work. Welcome voice message at splash screen works, but any other voice does not. Haptic works, but no voice is heard. I trie...
by tomismrkolj1
Fri Jun 17, 2016 4:30 am
Forum: ersky9x
Topic: Adding MAVLINK support
Replies: 571
Views: 42918

Re: Adding MAVLINK support

Hi,

do you think that algorhitm for calculating mAh from current is the same in apm and 9xr pro?

tomi
by tomismrkolj1
Thu Jun 16, 2016 8:47 pm
Forum: ersky9x
Topic: Adding MAVLINK support
Replies: 571
Views: 42918

Re: Adding MAVLINK support

Hi, Mike, did you find solution for correct value for total charge consumed. Today I was flying and APM reported 2625 mAh of total charge consumed, which is nearly the same as reported by my batt charger. However 9xr pro reported 2254 mAh. I don't know how to use scaler to correct for this differnce...
by tomismrkolj1
Tue May 31, 2016 7:31 am
Forum: ersky9x
Topic: Adding MAVLINK support
Replies: 571
Views: 42918

Re: Adding MAVLINK support

Ok it is not Ctot but CurrTot on APM. CurrTot is total charge calculated from current measurement by powermodule since APM boot and is one of the variables in Mavlink stream. I am not sure how to compare current seen by APM to the value on 9xr, since telemetry link drops, when USB is connected to th...
by tomismrkolj1
Mon May 30, 2016 8:48 pm
Forum: ersky9x
Topic: Adding MAVLINK support
Replies: 571
Views: 42918

Re: Adding MAVLINK support

Hi, Mike could you add Ctot variable to the telemetry stream, please? I managed to calibrate power module to show current readings and total consumed charge (mAh) on APM dead on (less than 1% difference) by correcting voltage/amps factor in APM settings to match Ctot (total charge consumed) of the A...
by tomismrkolj1
Thu May 19, 2016 2:54 pm
Forum: ersky9x
Topic: Adding MAVLINK support
Replies: 571
Views: 42918

Re: Adding MAVLINK support

It works now!
Great.

Out of curiosity Mike: how much bandwith on frsky telemetry is left for further variables?

tomi
by tomismrkolj1
Thu May 19, 2016 1:58 pm
Forum: ersky9x
Topic: Adding MAVLINK support
Replies: 571
Views: 42918

Re: Adding MAVLINK support

s.port

tomi
by tomismrkolj1
Thu May 19, 2016 12:39 pm
Forum: ersky9x
Topic: Adding MAVLINK support
Replies: 571
Views: 42918

Re: Adding MAVLINK support

Hi,

tested it. It does not appear to work. Vspd stays 0.0. I did not fly but lifted the plane by hand.
Mission planner shows vertical speed data up to 1m/s when lifting quickly. I tried to use scaler to amplify Vspd by 100 but no change.

tomi
by tomismrkolj1
Thu May 19, 2016 8:16 am
Forum: ersky9x
Topic: Adding MAVLINK support
Replies: 571
Views: 42918

Re: Adding MAVLINK support

Hi,

Mike, is Vspd already being sent through telemetry or do you have to enable it in arduino code?
My brother and I need Vspd to get vario working on 9xr pro.

tomi
by tomismrkolj1
Wed Apr 27, 2016 11:32 am
Forum: ersky9x
Topic: Adding MAVLINK support
Replies: 571
Views: 42918

Re: Adding MAVLINK support

Tnx. I am still afraid of what could happen if APM did reset in the air. It can be seen from the log that Vcc went down to 4.6V range quite often. The solution i see now is following: PM for measuring voltage and current of the main battery, but PM not powering APM (so removing 5V leads from 6 pin P...
by tomismrkolj1
Wed Apr 27, 2016 8:03 am
Forum: ersky9x
Topic: Adding MAVLINK support
Replies: 571
Views: 42918

Re: Adding MAVLINK support

Ok here is the story: it is the power module. CLONE. The second one...Which i paid 20 euros, just to be sure to get good quality stuff... It just has enough power to drive apm+mini pro+gps + airspeed sensor+optionally x8r. I say optionally because if i switch 9xr pro transmitter off, FasV is stable,...
by tomismrkolj1
Mon Apr 25, 2016 9:50 pm
Forum: ersky9x
Topic: Adding MAVLINK support
Replies: 571
Views: 42918

Re: Adding MAVLINK support

It seems to be power issue with APM, but i am not sure why. 10 day ago, when FasV was working OK, APM was not connected to rx, but was used just to show flight data. It was powered by powermodule. Now I connected APM inputs to rx and outputs to servos, one of servo output is connected to motor esc b...
by tomismrkolj1
Mon Apr 25, 2016 9:18 pm
Forum: ersky9x
Topic: Adding MAVLINK support
Replies: 571
Views: 42918

Re: Adding MAVLINK support

Hi, just got worried about new issue that occured today. FasV fluctutates +/- 0.2V wildly around correct voltage on 9xr pro display. In mission planner it does not fluctuate more than few 0.01V. FasV worked Ok and stable 10 days ago (no fluctuation at all!). All I have changed was configuring APM ch...
by tomismrkolj1
Sun Apr 03, 2016 10:23 am
Forum: ersky9x
Topic: Adding MAVLINK support
Replies: 571
Views: 42918

Re: Adding MAVLINK support

I agree, great work Mike.
Tested Gspd and it works.
Also airspeed works now without need for scalers.

tomi
by tomismrkolj1
Mon Mar 28, 2016 5:34 pm
Forum: ersky9x
Topic: Adding MAVLINK support
Replies: 571
Views: 42918

Re: Adding MAVLINK support

Hi, yesterday I had more time to test airspeed sensor. It works very nice. I used esky9xr scaler to get the reading right (just defined 1 decimal in the scaler, no multiplier or divisor). Then I wanted to compare gps speed and airspeed, but somehow I don't get reading of Gspd. It stays at 0. Gps has...
by tomismrkolj1
Sun Mar 20, 2016 7:33 am
Forum: ersky9x
Topic: Adding MAVLINK support
Replies: 571
Views: 42918

Re: Adding MAVLINK support

Correction:

i tried again an it seems that Aspd is indeed 10th multiple of APM airspeed. So it works Mike.

tnx.

tomi
by tomismrkolj1
Sun Mar 20, 2016 7:04 am
Forum: ersky9x
Topic: Adding MAVLINK support
Replies: 571
Views: 42918

Re: Adding MAVLINK support

Hi,

tried with newest version
first I had to remove "f" from airspeed * 10f, otherwise arduino sketch did not compile.
Now 9xr pro shows Aspd of 40 to 50 fluctuating which seems cool, however it is not 10th multiple of 0.8 to 1.8 m/s as meassured by APM.

tomi
by tomismrkolj1
Sun Mar 20, 2016 6:23 am
Forum: ersky9x
Topic: Ersky9x Test Versions
Replies: 53
Views: 47286

Re: Ersky9x Test Versions

Mike,

I tried newest verisons. Arudino did not want to compile so i removed "f" after airspeed * 10 (instead airspeed * 10f).
Now numbers fluctuate (40 to 50), but do not seem to be mutiple of 0,9 to 1,8, which is usual fluctuation when pitot tube is closed - not in flight).

tomi
by tomismrkolj1
Sat Mar 19, 2016 10:57 am
Forum: ersky9x
Topic: Adding MAVLINK support
Replies: 571
Views: 42918

Re: Adding MAVLINK support

Tried with mini pro 32k and return 5 test.
Aspd shows 0.

Mike: is it Aspd after TmOK value in custom telemetry menu, that should show airspeed?

tomi
by tomismrkolj1
Sat Mar 19, 2016 6:44 am
Forum: ersky9x
Topic: Adding MAVLINK support
Replies: 571
Views: 42918

Re: Adding MAVLINK support

Hi,

I tried return 5 test, and Aspd is still 0.

Will solder my new mini pro 32k after breakfast and test with it.

tomi
by tomismrkolj1
Fri Mar 18, 2016 7:45 pm
Forum: ersky9x
Topic: Adding MAVLINK support
Replies: 571
Views: 42918

Re: Adding MAVLINK support

Hi,

tested the new code from github. Aspd still 0 on S.port x8r, mini pro 16, 9xr pro.

tomi
by tomismrkolj1
Fri Mar 18, 2016 6:30 pm
Forum: ersky9x
Topic: Adding MAVLINK support
Replies: 571
Views: 42918

Re: Adding MAVLINK support

I am using SPort of x8r.

tomi
by tomismrkolj1
Fri Mar 18, 2016 3:58 pm
Forum: ersky9x
Topic: Adding MAVLINK support
Replies: 571
Views: 42918

Re: Adding MAVLINK support

Hi,

i tried new firmware version on mini pro 16k and 9xrpro. Airspeed does not work. Value Aspd stays at 0 all the time, eventhough apm shows normal airspeed fluctuation (1.3 to 1.8 m/s) through Mission Planner. Other telemetry displays normally on 9xr pro display, so mini pro does work.

tomi

Go to advanced search