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Introduction 

Eepskye is a computer program designed to support the Ersky9x firmware used in the Turnigy 

9XR Pro transmitter. This software will allow you to backup, edit and share model definitions 

and adjust transmitter settings. Eepskye can also simulate how the outputs of the servo 

channels will respond to various control inputs and programmed mixes.  

Eepskye9x can make setting up a new model easier and quicker by allowing you to use the 

keyboard, mouse and larger screen of a PC. It can allow you to store as many different models 

as you want on the computer and download them to the transmitter when needed. And Eepskye 

offers an easy way of loading new firmware onto the radio. 

At present, Eepskye runs on Windows XP, 7 or 8 and Macintosh. Work is under way to create a 

version for Linux. 

There are other open source programs that perform similar functions. To avoid incompatibilities, 

make sure you use Eepskye to manage the Ersky9x firmware in your 9XR Pro transmitter. 

Basic Concepts 

Memory 

The purpose of Eepskye is to enable you to use a computer to work with and manage the 

contents of the memory of your Turnigy 9XR Pro transmitter. There are three kinds of memory in 

the radio: Flash, EEPROM and SD card. 

Flash Memory 

Flash memory is where the radio's firmware or "operating system" resides. "Flashing the radio" 

means replacing the firmware, usually to upgrade to a newer version. Flashing requires a 

special procedure, not merely copying the firmware file. The Ersky9x firmware used in the 9XR 

Pro includes a “boot loader” to enable the transmitter to flash its own firmware (for details see 

the manual 9XR: Communicating with a Computer). The Eepskye program can also be used to 

flashed firmware, as explained later in this manual. 
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EEPROM 

The EEPROM (Electrically Erasable Programmable Read-Only Memory) stores general radio 

settings and the individual model memories. EEPROM can be read by the Eepskye program, 

the contents can be edited or stored on the computer, and files on the computer can be copied 

to the transmitter. 

Micro-SD Card 

The 9XR Pro includes a Micro-SD card (the kind used in many smartphones) that can store 

firmware files and various other information such as voice files. In addition, Ersky9x can back up 

individual models to the card and restore them to the transmitter, which the Eepskye program 

can access and edit the resulting files. For details see the manuals 9XR: Communicating with a 

Computer  and 9XR: Ersky9x Explained. 

Connecting to the Computer 

The boot loader portion of the Ersky9x firmware used in the 9XR Pro allows the transmitter to 

connect to the computer via a USB cable. The required cable has a mini connector on one end 

and a full-size connector on the other (see picture below to identify the required mini connector). 

Note that some USB cables of this type support charging only and do not allow communication. 

The mini-USB socket is located under the rubber flap on the bottom of the transmitter, next to 

the Micro-SD card slot and the audio jack, as shown below.  

 

To set up a USB connection between the transmitter and a PC, start with the transmitter turned 

OFF. Hold both horizontal trim switches (Aileron and Rudder) TOWARDS THE CENTER and 

turn ON the transmitter. You will see “Boot Loader Ready” on the transmitter screen. From this 

point on, procedures are different for PCs and Macintosh computers. 

Windows PC 

Plug the USB cable into the transmitter and the computer. Press the connector firmly into the 

transmitter connector and make sure it is fully seated. The computer should recognize the USB 

connection and produce the “successful connection” sound. You will now see “Connecting” on 

the screen, confirming that the USB link is working. 

On the computer you will see two new drives: ERSKY_9X is the transmitter’s EEPROM, while 

the other drive represents the Micro-SD card and will be named accordingly. Drive letters will 

depend on your computer’s configuration. Access to the drives should be almost immediate. 
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To disconnect the transmitter from a Windows computer, first use the command “Safely Remove 

Hardware and Eject Media”. Then turn OFF the transmitter and unplug the cable.  

Macintosh 

Using a Macintosh computer, loading the SD card via a USB connection can take over five 

minutes. Consequently, it is recommended that Macintosh users access the contents of the SD 

card directly by removing the card from the transmitter and inserting it into the computer (using 

a suitable adapter or card reader).  

To connect a Mac with the transmitter via USB, start with the transmitter turned OFF. Hold both 

horizontal trim switches (Aileron and Rudder) TOWARDS THE CENTER and turn ON the 

transmitter. You will see “Boot Loader Ready” on the transmitter screen. At this point, press the 

TRN switch once to turn off access to the SD card; “SD card Off” will flash repeatedly on screen. 

The computer can now access the EEPROM in the transmitter (but not the SD card). This is 

what is required to run the Eepskye program, which does not use the SD card. 

Setting up the Eepskye Program 

The Eepskye program comes in a file called eePeInstall.exe that includes both the eepe.exe 

and eepskye.exe files. The eepe.exe file is used with 9x and 9XR transmitters running ER9x 

firmware. The 9XR Pro runs Ersky9x firmware, so you must use eepskye.exe, as explained 

below. 

Installing Eepskye 

To download the program, go to: https://code.google.com/p/eepe/  

Windows PC 

Select Download Windows Installer and save eePeInstall.exe to the desktop or another 

location where it can easily be found. Double click eePeInstall.exe. This will install the program 

in a folder called ‘eepe’ under ‘Program Files’ or ‘Program Files (x86)’ on the computer. The 

folder will include both eepe.exe and eepskye.exe, the one we need for the 9XR Pro.  

To make Eepskye readily accessible, go to the eepe folder and find the file eepskye.exe. Right 

click on it and select ‘Send to’. Choose ‘Desktop (create shortcut)’ and click on it. You now have 

a shortcut to start the Eepskye program from the desktop. 

Macintosh 

Download the file EepskyeMac.zip. It will automatically unzip itself and become Eepskye.dmg. 

Double click on that file and a folder named Eepskye will appear. Drag the icon to your 

Applications folder to install it. Drag the new icon to the dock to create a shortcut if you wish. 

Eject the disk image and the Eepskye.dmg file. 

Setting Eepskye Preferences 

Double click on the desktop shortcut to open Eepskye. A window will open. 

Go to File>Preferences and open the dialog window. You will see: 

https://code.google.com/p/eepe/
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If you select a language other than English, you will need to restart eepskye. 

Enter Channel Order and Stick Mode, using the same settings established in the Radio Setup 

screen of the transmitter (for details see the manual 9XR: First Steps with Ersky9x).  

Select both of the “Check for updates” boxes (recommended). 

“Show splash screen” determines whether the welcome screen is displayed on the transmitter at 

startup (optional). 

In “Version to download” select ersky9xr.  

Click OK. 

Testing Eepskye 

Go to Burn, Configuration and verify that ‘Use SAM-BA’ is NOT checked.1 Close the window. 

Now connect the 9XR Pro to the computer using the USB cable. As explained previously, this 

requires turning on the transmitter in boot loader mode, i.e., with both horizontal trim levers 

towards the centre. You should see ‘Boot Loader Ready’ on the transmitter screen. Then plug in 

the USB cable and ‘BUSY’ should appear. 

Under the Burn menu within eepskye, press Read Memory From Tx. You should see “Data 

Transfer” and a progress bar, followed by “Operation successful.” The process should take just 

a few seconds. This copies the EEPROM information in the transmitter to eepskye on the 

computer. 

                                                           
1
 SAM-BA is a program available from the manufacturer of the Atmel chip used on the main 9XR Pro circuit board. 

Originally, SAM-BA was required to install firmware and connect the transmitter to the computer, but current 
firmware includes a boot loader that provides these capabilities. SAM-BA is now required only to correct problems 
with the firmware installation (see the manual Using SAM-BA to “Unbrick” the 9XR Pro). 
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A list of model memory slots, including any models already created, will appear in the Eepskye 

main screen. The file should be saved to your computer with a descriptive name (such as 9XR 

Pro BU 001) in a location where it will be available as a backup (such as ‘9XR BU Files’). The 

program will add the extension ‘.bin.’ 

This test verifies that the Eepskye program is working and communicating properly with the 

computer. 

Updating Eepskye and Ersky9xr 

From time to time, updates are issued for the Eepskye program. Generally, these add new 

capabilities or fix minor issues and are optional. Nevertheless, it is recommended that you keep 

the firmware reasonably up to date. 

There are two methods for doing the update:  

The easy way is to check the relevant boxes in preferences, as described above. For either PC 

or Macintosh, this automatically downloads the latest versions of both program and firmware 

files and prompts you to install the firmware. 

Alternatively, to upgrade Eepskye manually go to the 9XR Pro section of the Open RC Forums 

web pages and download the latest Eepskye file in zip form.  

Windows PC 

Unzip the Eepskye file to your eepe folder, replacing the existing eepskye.exe file (if you want to 

keep the old file, first rename it). The new file will run when you start the program using the 

existing icon.  

Macintosh 

The new EepskyeMac.zip file will automatically unzip itself and become Eepskye.dmg. Double 

click on it. A folder named Eepskye containing the Eepskye software will appear. Drag the icon 

to your Applications folder and “replace” the existing software. The existing shortcut in the 

toolbar should still work.  

To install new Ersky9xr firmware manually, follow the instructions in “Flashing the Firmware with 

Eepskye” (see page 9). 

General Description of Eepskye 

When you launch Eepskye you will see a row of drop-down menus along the top line: File, Edit, 

Burn, Telemetry, Window, and Help. These give access to all the commands required to use 

Eepskye. In this section we will review the available commands as they appear in the menus. 

Note that many of the most-used commands are quickly available through the icons that appear 

below the drop-down menus. Some are also accessibly in certain contexts by right-clicking.  
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File Drop-Down Menu 

File>New  

Opens a window within Eepskye showing a generic binary file called ‘document1.bin’. This is an 

empty file ready to be filled in and uploaded to the transmitter. It will contain both individual 

model definitions and the general radio settings.  

General Settings in the top line of the document represents the radio setup data. Double click 

on it and you will see a form corresponding to the settings on pages 1/11 and 2/11 of Radio 

Setup on the transmitter (press long left from the Home screens). 

Up to 32 model definitions can be stored in the numbered memory slots that make up the rest of 

the document. 

Note that if you write such a .bin file to the transmitter it will replace all of the current settings 

stored in the EEPROM.  

File>Open 

Enables you to find and open EEPROM files on your computer. These can be previously made 

backups from the transmitter, model setups created on the computer, files downloaded from the 

internet, etc. 

Files from previous back-ups will include your General Settings (at the top) as they were at that 

time. If you have changed the Radio Setup in the meantime, the General Settings will be out of 

date.  

To add a model from elsewhere to the radio, the safest way is to start by reading the memory 

from the radio (Burn>Read memory from Tx); this will include the radio’s current general 

settings, as well as the existing models. Then drag the file containing the new model to an 

available slot. Finally, upload the whole file back into the radio (Burn>Write memory to Tx). This 

will overwrite everything in the EEPROM but it will conserve your existing general settings and 

model definitions and add the new model. 

Files can also be opened by dragging them onto the main window of Eepskye. Several files can 

be open simultaneously, allowing you to copy/drag models or settings between files. 

Note that trying to open a firmware file with Eepskye will generate an error message saying that 

the file is invalid, the file size is wrong or something similar. This doesn't really mean that the 

firmware is invalid, but simply that it is not an EEPROM settings file.  

File>Save or File>SaveAs 

These commands save the information in the currently open window to your computer as a 

binary file (with the extension .bin). ‘SaveAs’ allows you to rename the file. 

File>Load Model Settings, File>Save Model Settings 

This pair of commands enables you to save and retrieve the settings for an individual model in 

the form of an .eepm file. By contrast, regular EEPROM files (.bin) consist of the entire contents 

of the memory, including all 32 memory slots as well as the general radio settings. One 

advantage of the .eepm approach to saving model information is that it enables an individual 

model file to be transferred to a different radio without affecting the general radio settings. 
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To create a .eepm file, select a model within an open EEPROM file and press Save Model 

Settings. You will have a choice as to the location on the computer and the file name. 

To open a model settings file, select an available slot in an open EEPROM file. Use Load Model 

Settings to find the appropriate .eepm file and load it into the slot. The modified EEPROM file 

can then be edited, simulated, saved to the computer, uploaded to the radio, etc.  

A file created on the SD card by the Ersky9x Backup command in the Model Select actions 

menu is in the .eepm format and can therefore be accessed and opened by the Eepskye 

program using the File>Load Model Settings command. It can be inserted into a blank slot in an 

EEPROM file and edited in the normal way. 

Note that an .eepm file can only be opened in Eepskye by using the File>Load Model Settings 

command to load it into an EEPROM file. The “open” command does not work in this case. 

File>Simulate 

Opens the simulator screen to show how, for the selected model in an EEPROM file, the output 

channels respond to stick or pot movements and switch positions. See the “Simulating a Model” 

section later in this manual. 

File>Print 

Enables printing of a copy of your model settings. 

File>Preferences.  

Allows setting of various parameters that apply to Eepskye as a whole: 

Language. Select preferred language from: German, Spanish, Hebrew, French, Portuguese 

and Russian. Changing language requires a restart of the Eepskye program. 

Default Channel Order. Select preferred order from the drop down list. The new order will be 

applied when creating a new EEPROM document. 

Default Stick Mode. Select preferred order from the drop down list. All four modes are 

available. The mode will be applied when creating a new EEPROM document. 

Check for Updates on Startup. If the boxes are checked, Eepskye will search at launch for 

updates for both Ersky9xr and Eepskye. 

Show Splash Screen. Determines whether or not the welcome screen will be displayed 

when starting Eepskye. 

Version to Download. Select preferred firmware from the drop down list. For the 9XR Pro 

choose Ersky9xr. 

Current Version. Shows the firmware version installed on your radio and allows you to check 

for and download an update. 

File>Switch Layout Direction.  

Changes the order of the drop-down menus and the alignment of the menu commands. 

Exit  

Closes the program. Warns if files are unsaved. 
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Edit Drop-Down Menu 

Edit>Cut, Edit>Copy, Edit>Paste.  

Enable performing these actions on an open document. 

Edit>Eeprom Info.  

Summary of the file attributes for the EEPROM file selected. 

Burn Drop-Down Menu. 

Burn>Write Memory to TX  

Sends to the radio the currently open and selected document. (If you have more than one 

window open, make sure to click on the one you want to transfer.) 

Burn>Read Memory from TX  

Reads the EEPROM contents from the radio, and opens them in a new document in Eepskye. 

The document is open for editing, but is not saved to disk automatically. 

Burn>Flash Firmware to Tx 

Flashes the radio's firmware from the selected file. Once the file is selected, you have the option 

to replace the default splash screen or to use the default image selected in preferences. See 

“Flashing the Firmware with Eepskye” later in this manual. 

Burn>Read Firmware from Tx 

Reads the firmware currently on the radio and writes it to a file on your computer as a backup. 

Click the entry, choose a location and filename, and save. 

Burn>Write EEPROM memory from File  

Enables a file on the computer to be selected and transferred as-is to the radio. This is the 

preferred way to restore a backup, as no processing is done by Eepskye.. 

Burn>Read EEPROM memory to File  

Reads the EEPROM contents from the radio directly into a file. This is the preferred way to back 

up your radio's settings as the information will be saved "as is" without processing by Eepskye. 

Click the entry, choose a location and filename, and save. 

Burn>Configure 

If you are using SAM-BA to access the transmitter, this is where you set the path, the USB 

driver and COM Port. Since SAM-BA is not required if Boot Loader is used for access, make 

sure the “Use SAM-BA” box is NOT checked. 

Burn>review Output 

Opens a window where the results of a Burn action can be reviewed. Applies only when 

SAM-BA is used. 

Telemetry Drop-Down Menu 

[This section of Eepskye is under development.] 
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One of the Telemetry screens is used to simulate the Winged Shadow How Hi device. If the 

serial output from the computer is connected to the serial port on an FrSky D-series receiver, 

the operation of the device can be tested by pressing the Start button. 

The other screen is used to read and set the alarms on a DJT or XJT transmitter module. The 

serial port on the computer is connected to the 4-pin connection on the module. With the 

module powered up, press the Start button. Press the “Read Alarms” button to view all the 

settings and change them to what is required. Then press the “Set Alarms” button. 

One or two received telemetry items can also be displayed. It is planned to increase the number 

of items in the future. 

These features work only with the FrSky hub communication protocol; both the DJT and the XJT 

have the hub connector, which can be used to set the alarms. 

Window Drop-Down Menu 

Window>Close, Window>Close All, Window>Tile, Window>Cascade, etc...  

These standard Windows commands allow you to manage the windows currently open in the 

Eepskye program. 

Help Drop-Down Menu 

Help>Ersky9xr Users Guide  

Opens the current manuals for Ersky9xr and Eepskye. [TO BE CONFIRMED] 

Help>Customise Splash Screen  

Opens a dialog box which allows a new image to be loaded as the welcome screen for the 

transmitter. See “Customizing the Splash Screen” later in this manual. 

Help>About  

Software name, author and version. 

Help>Contributors  

A list of the many contributors to the project. 

Help> Check for updates  

Click here to get the latest update according to your choices in File>Preferences. 

Flashing the Firmware with Eepskye 

Flashing is the process of replacing the firmware or operating system of the transmitter.  

Before starting, you may want to use Burn>Read Firmware from Tx to save a backup copy of 

the current firmware.  

You may also want to make a backup of the current general settings and models stored in the 

EEPROM. Use Burn>Read EEPROM memory to file for this purpose. Note that it is not strictly 

necessary to make such a backup with the 9XR Pro, as the firmware and the settings are stored 

in separate portions of memory, but it is good practice to have a safety net in the unlikely event 

that something goes wrong. 
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To flash new firmware to the transmitter, first go to File>Preferences and press download to 

get the latest version of the Ersky9xr firmware. This assumes you have already set appropriate 

preferences for the 9XR Pro, as discussed above. 

Now power up the transmitter in boot loader mode by holding both horizontal trim switches 

(Aileron and Rudder) TOWARDS THE CENTER and turning ON. You will see “Boot Loader 

Ready” on the screen.  

Plug the mini-USB cable into the transmitter and the computer. You should now see “BUSY” on 

the transmitter screen, indicating that the connection to the computer is established. 

You can now upload the new firmware using Burn>Flash Firmware to Tx. This presents you 

with a file select dialog allowing you to choose the firmware version to flash. Click OK and the 

flashing begins. You should very quickly see “Operation Complete.” Click OK. 

You have now flashed the new firmware into your radio. Turn your radio off. Close Eepskye and 

disconnect the USB cable. 

Note that there are other ways to flash firmware to the transmitter. See the manual 9XR Pro: 

Communicating with a Computer for details. 

Creating, Editing and Importing Models with Eepskye 

To understand the process of creating and working with models using Eepskye, keep in mind 

that all of the general radio settings as well as the individual model settings are stored together 

in the transmitter’s EEPROM. Hence, if you create a new file in Eepskye and copy it to the 

transmitter, it will replace everything that is there. Think carefully before using the command 

‘Write EEPROM memory from file’! Do a backup before you change things! 

In creating new models or editing existing ones, when you work in a different file you will usually 

need to transfer the resulting model to a backup of the transmitter’s current EEPROM 

configuration. This will ensure that you preserve the other models and the radio settings (such 

as stick configuration).  

Creating a New Model 

Launch eepskye. Go to File>Open.  

Find and open the file you downloaded from the radio when you backed up the EEPROM. (If 

you didn’t save it, just make a new one.)  

Use File>SaveAs to rename the file so you preserve the back up. For example, you could use a 

name that includes today’s date such as 9XR Pro 2014-02-07. Save to the folder you have 

chosen to use for this purpose.  

At this point you should have on-screen a window listing any existing models and the unused 

slots.  

Here we see the generic MODEL 1 that always appears, plus a previous test model we created 

while experimenting with the transmitter: 
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To create a new model from scratch in Eepskye, double click on a blank model slot in a 

document. The model settings edit screen will appear: 
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Along the top is a row of 13 tabs, one for each page of the model setup. If you turn on your 

radio and long press the right navigation key once, select a model and then press once more 

right, these are essentially the same 13 pages you will see on your radio. 

Using these pages on your computer is just like programming directly on the transmitter, except 

that you have the advantage of a keyboard, mouse and big screen. You will find that it’s much 

easier to do some things, such as setting expo and dual rate, or adjusting curves, this way. 

To understand them and to know how to fill in all the fields please refer to the manuals First 

Steps with Ersky9x and Ersky9x Explained. You can create a model here on your computer and 

then upload it to the transmitter, just as you can create a model on your transmitter and then 

download it to here. 

Note that the Templates in Eepskye work just like those in Ersky9x except that here you double 

click on the required template. If you choose something like V-Tail or Elevon/Delta you will get a 

warning that you are about overwrite existing mixes. 

When you have created the model, you can test it out by clicking on Simulate at the bottom of 

the editing screen. See “Simulating a Model” later in this manual. 

Finally, save the file. Now decide if you want to upload the file to the transmitter, thereby 

overwriting the models and general settings in the EEPROM. Let’s suppose you want to work on  

Editing a Model 

If instead of double clicking on a blank model slot you choose an existing model, then you will 

see the various pages of the editing screen populated with the parameters that describe the 

model – the mixes, expo and D/R settings, limits, curves, etc.  

Suppose we have already created a basic model created by using the Simple Four-Channel 

template. The T-Cut Template has also been installed (giving an extra mix on Channel 1).  

From this simple starting point we can proceed to edit and embellish with additional mixes to do 

jobs such as provide a retract gear switch on Channel 5, or a mix from aileron (Channel 2) to 

rudder (Channel 4) to help coordinate the turns. 

Other aspects of the model can also be edited, such as the expo and dual rate settings, servo 

travel limits and reversing, timer settings, etc. For an introduction to the possibilities of 

programming, see the manual First Steps with Ersky9x.  For more detail, see Ersky9x 

Explained. 

When editing is finished and the results have been tested in the Simulator (click the bar at the 

bottom of the page), it’s time to save the file (File>Save or File>SaveAs). Then the file can be 

uploaded to the transmitter (Burn>Write EEPROM memory from file). 

Note that everything we can do to edit the model in Eepskye can also be done in the transmitter. 

The advantage of doing it here is convenience and the ability to save the file to the computer. 

Below is an example of what you might see if you went to the Mixer screen for a model called 

Pirate in the Model 13 memory slot. 
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Importing a Model 

You can import a model by bringing in an entire EEPROM file from another 9XR Pro and then 

dragging the desired model over to an EEPROM file downloaded from your own transmitter. 

What you should NOT do is to load a file from another transmitter into your own 9XR Pro, as 

doing so would bring in all the other models and general settings and wipe out all of your own. 

A more convenient way to exchange model files with someone else who has a 9XR Pro is to 

use an .eepm file. One way is to use the Model Select>Backup command to save the model to 

the SD card. Another is to use Eepskye to save the EEPROM information of the first transmitter 

to file. Then File>Save Model Settings is used to extract the desired model to an .eepm file. 

The command File>Load Model Settings within Eepskye is then used to insert the .eepm file 

into either a blank EEPROM file. There you can edit and modify it and then test out your 

programming with the simulator. 

The file can then be copied and pasted or just dragged and dropped into an EEPROM file 

downloaded from your transmitter. The amended file can then be uploaded back to the 

transmitter with the imported model included. 

Adjusting the General Settings 

The General Settings in Eepskye correspond to the Radio Setup pages in the transmitter 

(from the home page, long press the left navigation key once) and apply to all models. To edit 

them, in the top line of the document window, double click on “General Settings”. You will see a 

page that presents essentially the same choices as the Radio Setup pages on the transmitter, 

though organized differently: 
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The tabs along the top of the page correspond to the Radio Setup pages in your transmitter 

programming. You can edit the General Settings for the Setup, Trainer, and Calibration pages 

here, upload these settings to the radio and save them as a backup. Again, to understand the 

various fields please refer to the manuals First Steps with Ersky9x and Ersky9x Explained. 

Simulating a Model 

Highlight a model in a document.bin file. Go to File>Simulate and a click on the command, or 

just click on the Simulate bar at the bottom of the edit screen. 

The graphical representation of the radio appears. The switches can be turned on or off. A green 

background denotes the switch in the ON position. The sticks can be moved and the direction of 

travel seen in the lower half of the screen. The effect of mixes can be seen when the controls 
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are moved. The direction and extent of the output can be seen and changed if necessary before 

uploading the file to the radio. 

Here’s what the Simulator looks like for a four channel model. In this example, the sticks have 

been set to hold so that the results of moving them from center can be seen: 

 

Splash Screen 

The splash screen image resides within the firmware and is displayed at start-up. To change the 

splash screen you must insert a different image into the firmware.  

To see the existing splash image within the firmware file, go to the Help>Customize Splash 

Screen within Eepskye. Click on “Load From Binary” and select the firmware file you want to 

modify (ersky9xr_rom or similar). You will see something like: 
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To create a new or modified splash screen requires the use of an application such as Paint. The 

image must meet strictly defined requirements: the file can be in binary format (.bin) or bitmap 

format (.bnp, .pbm, etc.); it can be inverted if necessary but must be monochrome black and 

white, 2 bit, 128 x 64 pixels. The pilot name must be 8 pixels high and can be up to 60 pixels 

wide.  

Here are some examples of possible images: 

                 

To insert a new splash image into the firmware file, go to the Help>Customize Splash Screen 

within Eepskye. Click on the “Load Image“ button. Fill in the file name or browse to the new 

image and click Open. This will display the image inside the dialog box. If you are satisfied with 

the image, click on “Save to BINARY”, making sure you select the correct firmware file for 

modification. This inserts the image into the firmware instead of the existing one and saves the 

firmware file back to the folder in which it was stored.  

The firmware file including the new or modified splash screen can now be flashed to the 

transmitter, as described above. Turn OFF the transmitter and restart it to see the new splash 

screen. To open the image already within the firmware, click on “Load from BINARY” and find 

the relevant firmware file (ersky9xr_rom or similar). Open this file. An image will appear on the 

dialog box screen, such as: 

You can also copy an image from one firmware file to another. Start by going to Help>Customize 

Splash Screen within Eepskye. Click on “Load from BINARY” and find the firmware file that is to 

provide the image. Open the file and you will see the image. The image may then be copied into 

another firmware file by clicking on “Save to BINARY” and selecting the target file. Press Save 

and you should see “Successfully Updated….” Close the dialogue and Eepskye. 
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Further Information 

For additional information to help you understand and make best use of your Turnigy 9XR Pro, 

see the other manuals in this series and/or go to one of the forums dedicated to this transmitter 

and the open source firmware it uses. 

9XR Pro Manuals 

The following manuals are designed to help you get the most out of your Turnigy 9XR Pro. They 

are available at: http://openrcforums.com/forum/viewforum.php?f=7 

1. 9XR Pro: Introduction to the Hardware 

2. 9XR Pro: First Steps with Ersky9x 

3. 9XR Pro: Ersky9x Explained 

4. 9XR Pro: Communicating with a Computer 

5. 9XR Pro: Using Voice with Ersky9x 

6. 9XR Pro: Using the Eepskye Program 

7. 9XR Pro: Glossary of Terms 

Internet Forums 

Help is always just a few clicks away on the internet forums where experienced Ersky9x users 

volunteer their knowledge and experience. Many of these people have been developing the 

firmware for years without remuneration; all they ask is donations to fund further development. 

Open RC Forums: http://openrcforums.com/forum/index.php 

Ersky9x index page: http://openrcforums.com/forum/ 

9XR index page: http://openrcforums.com/forum/viewforum.php?f=70 

NOTICE 

Ersky9x and Eepskye are free open source software, independently developed. This manual is 

provided to help you understand and use them specifically for the Turnigy 9XR Pro transmitter, though 

much of the information also applies to the Sky replacement boards produced as an upgrade for the 

9x transmitter. 

You can redistribute the software and/or modify it under the terms of the GNU General Public License 

version 2 as published by the Free Software Foundation. You can also freely quote from, redistribute 

and/or modify this manual; in doing so please acknowledge the source and any changes. 

The program and the manuals are distributed in the hope that they will be useful, but WITHOUT ANY 

WARRANTY; without even the implied warranty of MERCHANTABILITY or FITNESS FOR A 

PARTICULAR PURPOSE. See the GNU General Public License for more details. In using them, you 

agree that you accept all responsibility. 

For more information go to: http://openrcforums.com/forum/viewforum.php?f=7 
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